Updated iPhone 3G to 4.0.1, having major problems jailbreaking

Discussion in 'Jailbreaks and iOS Hacks' started by sweetpotato, Aug 11, 2010.

  1. sweetpotato macrumors newbie

    Joined:
    Aug 9, 2010
    #1
    Being the fool that I am, I updated my iPhone 3G (I'm T-mobile) to 4.0.1, it got restored. I decide to try jailbreak it using redsn0w 0.9.5 on my Mac OS X but it can't open it because it's an intel app and it can only open universal. I've also tried Pwnage Tool (an older version on 3GS mode) and blackra1n although that didn't do anything.

    I try to do it on my Windows 7 (AMD) and redsn0w 0.9.5 works fine but my iPhone only shows up briefly as a "Apple Mobile Device USB Driver" under Devices & Printers. Under properties it says:

    "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

    USB ports work fine, updates are installed, have reinstalled iTunes...

    PLEASE! Any advice is welcome: are there other ways to fix this? Another program to try besides redsn0w that'll get my iPhone working on a T-mobile SIM card?
     
  2. htownmade1984 macrumors regular

    Joined:
    Aug 5, 2010
    #2
    I would say restore it again and then jailbreak it with jailbreakme.com
     
  3. sweetpotato thread starter macrumors newbie

    Joined:
    Aug 9, 2010
    #3
    Okay, went to the site but it says I need to access it from my iPhone. Maybe I didn't make it clear, but my iPhone also needs to be unlocked. Are there any programs out there that can do that too?
     
  4. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #4
    Go to jailbreakme.com from your iPhone with Mobile Safari
    Slide to jailbreak
    Once done, Cydia will be installed on your iPhone
    From within Cydia, install ultrasn0w to unlock your iPhone
    http://blog.iphone-dev.org/post/901809518/grow-grow-ultrasn0w

    PS: from reading around this forum, 4.x runs like po0po0 on the 3G. You may be better off downgrading back to 3.x.x. Check the forum, there are threads about it.
     
  5. sweetpotato thread starter macrumors newbie

    Joined:
    Aug 9, 2010
    #5
    Thanks for your help! However, I decided to retry Pwnage Tool and I got in! I'll check on the downgrading part later on though : )
     

Share This Page