Updated Lion - Now screensharing/vnc doesn't work!

Discussion in 'macOS' started by Sean Dempsey, Dec 11, 2012.

  1. Sean Dempsey macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #1
    My Mac Pro has Lion on it, it can't do Mountain Lion. So I saw there were some updates for it, one of them being a screensharing update. So I ran it, and now I am unable to connect to the Mac Pro either through the OSX screensharing, or through a VNC app like Chicken of the VNC.

    Really aggrivating. I've restarted the Lion server, stopped and started the services multiple times, but when I try to VNC in it just times out. I am sorta clueless on where to go with this - I am not sure I can rollback the update, and since it's Lion, it's not like people are talking about it or that I can expect any fixes.

    Anyone experiencing this or know what I'm talking about? Anyone have any bright ideas on how to fix this??
     
  2. switon macrumors 6502a

    Joined:
    Sep 10, 2012
    #2
    Re: vnc...

    Hi Sean,

    Unfortunately, I'm not running Lion Server, so I don't know how much help I can be, but...I have had similar troubles after updates. I think I need a few more details concerning your system to be much help, but barring that...

    You are running Lion Server, and after an update you can't connect using vnc or Screen Sharing.app.

    Have you tried connecting using the IP address instead of the hostname? Sometimes updates will mess up the hostnames or, since you're running Lion Server you may also be running a DNS server, the update may have messed up the DNS server or its cache. If you are running DNS, then try clearing its cache with:

    dscacheutil -flushcache

    Your firewall configuration may also have been altered by the update, so also check your firewall and make certain that tcp, udp ports 3283 and 5900 are open and perhaps even tcp 5988, 5989, depending upon how your attempting to connect. Or check that all incoming connections to Remote Management are allowed.

    Without more specific information, this is all I can suggest for now.

    Good luck,
    Switon
     
  3. Sean Dempsey thread starter macrumors 68000

    Sean Dempsey

    Joined:
    Aug 7, 2006
    #3


    It is just Lion running on a Mac Pro as a server, but it's not the server OS.

    The OS X firewall is turned off because I am behind a firewall via the Airport Extreme.

    I tried connecting to the IP and hostname, and included the port 5900 as well.

    I didn't run the flushcache though, that's a good idea.

    I even tried disabling OS X screensharing and installing RealVNC vnc server, but I had the same result.

    I have a system rollback on an external drive that is before the update (its a superduper copy), so I can restore that if needed, but this Mac Pro 1.1 is stuck on Lion and I guess it's time to face the reality that it's not going to be updated or supported much longer.
     

Share This Page