Updated Parallels, Install Failed Now My Windows is Fried!

Discussion in 'Windows, Linux & Others on the Mac' started by karmacoma, Mar 15, 2007.

  1. karmacoma macrumors newbie

    Jun 6, 2006
    Hi everyone.

    I updated to the latest version of Parallels last night (knew it was going to be a mistake).

    I have Bootcamp and Parallels sharing the same partition.

    The new version of Parallels installed, and then when I booted into Windows using Parallels, it tried to install the new Parallels Tools for Windows. That installation failed partway through though (I think it ran out of hardrive space on my MAC partition).

    Since then, everything has gone poorly on the Windows side.
    I tried to bootup in Bootcamp and it complained that the C:\windows\system32\config\system file was missing or corrupted.

    So I used parallels and booted from my XP CD to walk through the "recovery" process that Microsoft outlined in its help documentation online (http://support.microsoft.com/kb/307545).

    Now I cannot boot into Bootcamp (it complains that the C:\Windows\System32\Hal.dll file is missing or corrupt).

    I also can no longer boot into parallels (it complains that the C:\Windows\System32\Config\System file is missing or corrupt).

    Does anybody have any idea on what I can do to fix this, or do I have to start over with a fresh Windows, Bootcamp and Parallels install?

    Thanks in advance!
  2. ChrisA macrumors G4

    Jan 5, 2006
    Redondo Beach, California
    That's pretty much the normal fix for Windows related problems -- reformat the disk and re-install, Repeat as required or every few months

    Save yourself some work. After you get it working make an image backup of the Windows partition then when it dies next time simply restore the image. Never keep your data on a Windows C: drive so the wipe and re-image can't kill your data.

Share This Page