Updated to 3.1.2 now ''sim card inserted not supported''

Discussion in 'Jailbreaks and iOS Hacks' started by Jackers008, Oct 9, 2009.

  1. Jackers008 macrumors member

    Joined:
    Mar 8, 2009
    #1
    So I upgraded earlier unaware that it would screw up my 2g iphone. Now I have the connect to itunes on my iphone's screen and ''sim card not supported'' on my computers itunes. The phone is an american model and used on an 02 contract in the UK so it has to be unlocked. Anything I can do as my phone is currently unusable :mad:

    Thanks.
     
  2. DannyBres macrumors 65816

    DannyBres

    Joined:
    Oct 30, 2007
    Location:
    UK
    #2
    try restoring to a pwned ipsw with the unlock
     
  3. Jackers008 thread starter macrumors member

    Joined:
    Mar 8, 2009
    #3
    Could you explain how you do that? Not really sure.

    Thanks.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Sorry you are having an issue with your phone.

    But, why is is that every time Apple releases a new firmware update some people who want their phone jailbroken or need it unlocked rush to update just like lemmings jumping off a cliff.

    And their next post always starts with "Help".

    Hint: Updating a phone with new firmware generally writes over the current jailbroken and unlocked firmware.
     
  5. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #5
    This tutorial should work for you, if you have a Mac: http://www.iclarified.com/entry/index.php?enid=4255

    If you're on Windows, you'll need to get a friend with a Mac to create the custom firmware.
     
  6. truncj macrumors member

    Joined:
    Jun 26, 2009
    #6

    :eek:Nooooo. If you're not sure what the correct answer is, do not reply to help thread acting like you're sure.

    Once the OP upgraded to 3.1.2, he upgraded the baseband. The current baseband (05.11.07) he upgraded to by installing 3.1.2 is currently non downgradeable/unlockable. However, you might have some hope afterall. Apparently a soft unlock for 5.11.07 is supposed to come out on sunday ( read here: http://appulo.tumblr.com/)
     
  7. apunkrockmonk macrumors 6502a

    apunkrockmonk

    Joined:
    Nov 20, 2005
    Location:
    Rochester, NY
    #7

    The OP has a 2G which will forever be unlockable and hasn't had a baseband update in quite some time.
     
  8. Jackers008 thread starter macrumors member

    Joined:
    Mar 8, 2009
    #8
    Yeah I know I was a fool for updating and I really should of done the research but s**t happens. I've tried using redsnow to restore back to the 3.0 firmware but once it has completed this and the phone is rebooted I just get the same connect to itunes and sim card not supported. I'm using itunes 8.2 if that can be of any help.

    Thanks.
     
  9. Jackers008 thread starter macrumors member

    Joined:
    Mar 8, 2009
    #9
    Seems I can't restore the phone either as itunes will not give me the option to. Any suggestions?
     
  10. Jackers008 thread starter macrumors member

    Joined:
    Mar 8, 2009
  11. hitekalex macrumors 68000

    hitekalex

    Joined:
    Feb 4, 2008
    Location:
    Chicago, USA
    #11
    Some people should really never attempt to jailbreak or unlock their iPhones..:rolleyes:
     
  12. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #12
    LOL
     
  13. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #13
    I dont understand these people. If you jailbreak / unlock a phone yourself you SHOULD be smart enough to know that new numbers mean changes. Changes are bad.

    Come on...
     
  14. jersey macrumors regular

    Joined:
    Jul 9, 2007
    #14
    What? How did you get it working again?
    Thats how these things work - you ask for help, people help you, and then you post what worked. Plus it may keep someone from asking the question in the future.
     
  15. Jackers008 thread starter macrumors member

    Joined:
    Mar 8, 2009
    #15
    I just restored my phone back to the 3.0 firmware then unlocked it again via redsnow. Was a mistake to update in the first place. My fault :D
     
  16. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #16
    Well, I have to admit I got caught by this too -- the original (EDGE / 2G) iPhone has stayed unlocked using official Apple updates for some time now. (And, AFAIK, no baseband updates in a long time for this iPhone). It seems to be an issue with the way redsn0w unlocks and/or activates the phone. When Pwnage Tool unlocks the phone, AFAIK, it stays unlocked and activated (for the EDGE iPhone ONLY). If one updates the phone after using redsn0w, though, it seems to fail to activate. I found this out the hard way, because the workaround for Youtube not working in 3.0 on unlocked phones required activation using an AT&T SIM and redsn0w.

    I have been trying different combinations this morning trying to understand this in more detail, while I be lazy on a Saturday morning and surf Yoox for expensive clothes. :p

    Oddly, after the upgrade to 3.1.2 locked the phone, a number of things did NOT work for me --

    - Installing a Pwnage unlocked 3.1 repeatedly fails with various iTunes errors
    - Installing official 3.0.1 (I had 3.0.1 before I did this update) in DFU mode also fails :confused:
    - Installing official 3.0 and then using redsn0w again works.

    It's the first two things that confuse me. I'm going to see if backtracking to 3.0, using redsn0w, and then installing the Pwnage version of 3.1 works....
     
  17. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #17
    Update on what I posted earlier... and I apologize, I haven't seen this written up elsewhere yet.

    - It's not redsn0w. I tried 3.1 unlocked via pwnage tool -> 3.1.2 and it also would not activate on a T-Mo USA SIM.

    - Once the phone was in this condition, once again, it would not restore to the 3.1 pwn'ed firmware. It would only restore back to 3.0 official (although I didn't try making a 3.0 unlocked firmware).

    - The furthest I could get, finally, was 3.1 unlocked, and it seemed like I even had to go through the circuitous route of re-unlocking 3.0 using redsn0w and then finally iTunes would install the 3.1 pwn'ed firmware. Now this is odd, too. 3.1 Pwn'ed would NOT install over 3.0 redsn0w in DFU mode. It would only install if I let iTunes restore the iPhone and then install the custom / pwned firmware in normal mode (you can do this when the phone is already jailbreaked, but I always thought that DFU was supposed to work in all situations....)

    This all seems very complicated, and certainly different than what I experienced up to now with the iPhone EDGE/2G/original phone.
     
  18. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #18
    PwnageTool does not support 3.1.2 yet, as the Dev Team clearly said in their blog.

    Pwned firmwares can only be installed on pwned phones. Once you upgraded, you lost yoru jailbreak and the ability to use PwnageTool until you had jailbroken again.

    That is because PwnageTool does not support 3.1.2, as the DevTeam clearly stated.
     
  19. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #19
    I never tried to use Pwnage tool on 3.1.2. Of course, I'm aware of that. As I said above, with previous versions of the firmware from 2.0 to 3.0.1 at least (not sure about 3.1), the original iPhone could be directly upgraded to the official firmware without losing its unlock. This is different now, as far as I can tell.

    This has never been true for the original iPhone before -- I understand that it's true for the 3GS, but not the 2G.

    And once again, this isn't what I'm talking about.
     

Share This Page