Updating Apps

TillysWily

macrumors regular
Original poster
Jun 8, 2011
204
16
Ok there are about 30 apps that are updating for some reason. They all say waiting under them. You can't click the app and make it start is does nothing. You can go into the app store and click the pause beside each one and they will stop. But when you click "update all" or just click "update" beside each one they do the same thing and then sometimes the phone will crash. IDK what the h*** is going on but its driving me crazy.
 

kenkamm

macrumors regular
Oct 25, 2008
110
0
After connecting to a wifi network, most apps downloaded, but there are a couple of lingerers.
 

Vertigo50

macrumors 65816
Apr 11, 2007
1,197
131
Try a restart of the phone.

Also, try going into the App Store and download any free app, so it will ask for your password. You might find that things start downloading then.

I think it's just a few bugs coupled with the fact that everyone on the planet is hammering Apple servers right now.
 

TillysWily

macrumors regular
Original poster
Jun 8, 2011
204
16
Yea I think it's a server problem bc nothing worked at all. So I just downgraded back to 6.1.4 and I will give it a few days and try again. Thanks anyways
 

frunkis54

macrumors 65816
Apr 2, 2009
1,346
0
mine does that everytime i restore from icloud. if go through and start tapping on apps it seems to kickstart them to downloading. usually works for me anyway.
 

philhyde

macrumors member
Oct 9, 2007
81
0
After connecting to a wifi network, most apps downloaded, but there are a couple of lingerers.
I'm glad you posted this. App store updates were hanging (not installing) for me this morning. Had wifi off. Turned wifi on and voila!

Thanks! :D