Updating from 3.1.3 and jailbreaking question

Discussion in 'Jailbreaks and iOS Hacks' started by JM8814, Apr 28, 2011.

  1. JM8814 macrumors newbie

    Joined:
    Apr 28, 2011
    #1
    Hey guys I'm new to this jailbreaking thing and had question and I hope one of you iPhone wizards can help me out. I was wondering if I am running on 3.1.3 firmware right now(my iPhone is currently jailbroken) if I were to update my firmware would I lose the jailbreak?? Would it unjailbreak my phone with a firmware update? I really don't want to try and re jailbreak it, will I have to or would the iPhone still remain jailbroken even if I update?? Help would be much appreciated guys!! Thank you in advance
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    What model iphone?
    Yes every time you restore or update you lose your JB and everything installed. You have to rejailbreak and install your stuff again.
     
  3. Darwing macrumors 6502

    Joined:
    Nov 5, 2009
    #3
    I don't understand why people wait so long to update... like if you have a 3gs there was no reason not to upgrade to 4.0 when it was a website based jailbreak.. your missing out on so many features fixes and upgrades.. I just dont get it
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Maybe he has an iphone 3G, and in that case he's better off at 3.1.3;)
     
  5. JM8814 thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #5
    its a 3GS.. damn that sucks, ok. the only reason is because my cousin just updated to 4.2 firmware and he said he cant jailbreak his phone at all. he's tried greenpoison, limerain, he said nothing seems to work so if i update im worried i wont be able to jailbreak my phone anymore
     
  6. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #6
    the newest firmware (as of today) 4.3.2 is jailbreakable with redsn0w rc 14.

    preserve your baseband if you ever want to unlock or increase resale
     
  7. Cha macrumors regular

    Joined:
    May 1, 2010
    #7
    I don't understand... 4.3.2 and different versions lower can be JB'ed. Are you trying to unlock as well? Then you may have issues based on the baseband.
     
  8. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #8
    Direct your cousin to iclarified.com, which has tutorials. He may have missed a step somewhere.
     
  9. hackthatphone macrumors 68000

    hackthatphone

    Joined:
    Jul 28, 2010
    #9
    These are the same people who still use Netscape 1.0 and Windows 3.11. Updating just doesn't matter to them.
     
  10. JM8814 thread starter macrumors newbie

    Joined:
    Apr 28, 2011
    #10
    thank you applejuiced, sbddude, eastercat!! and yes cha i would be trying to unlock as well, so i'll see if i can work out whatever issues it is i will have with the baseband.

    And darwing and hackthatphone, sorry we all know that you two guys are superior human beings, sorry not everyone can be as tech savvy as you guys.. I bet you guys are the type who sit up at the computer all day long and are pissed off at the world for no reason... go get laid or something...
     

Share This Page