updating jailbroken iPad from iOS 6.1.2 to iOS 8

Discussion in 'iPad Tips, Help and Troubleshooting' started by leejones1981, Dec 27, 2014.

  1. leejones1981 macrumors newbie

    Joined:
    Dec 27, 2014
    #1
    Hi all. I'm trying to update a jail broken iPad from iOS 6.1.2 to iOS 8. The jailbreak has apparently disabled the software update on the iPad itself. In iTunes, it says that 6.1.2 is the latest software, which is obviously wrong. I have tried downloading the correct iOS 8 firmware and shift+click to restore that ipsw; this doesn't work (error ex08000004). I have tried a plain restore in iTunes in recovery mode. This doesn't work either. It goes through the motions of downloading iOS 8, then the process just stops after the unpacking process, without any error. No changes are apparently made to the iPad.

    Essentially it seems update proof. I'm completely stuck. Any advice very welcome!
     
  2. a.borque, Dec 28, 2014
    Last edited: Dec 28, 2014

    a.borque macrumors newbie

    Joined:
    Dec 26, 2014
    #2
    Hello!
    There is a support-document from Apple for that error. If this does not help:
    I had a similar Problem when updating from 4.x to 5.x. AFAIR this was because the jailbreak software set some adresses of Apple-Servers to the loopback-device in hosts-file to prevent accidential updates. Therefor iTunes could not perform certain checks with the downloaded firmware and the update failed with a strange error.
    Another reason might be a wrong hardware-driver is selected for the device in recovery-mode.
    Please note that all this applies only to iTunes on Windows. I have no knowledge whether is works on Macs. (But at least there should be some kind of hosts-file?!)
    a.borque
     
  3. leejones1981 thread starter macrumors newbie

    Joined:
    Dec 27, 2014
    #3
    Thanks very much for the suggestion. However, I checked the hosts file and there was nothing there. (I am on Windows 7 btw.)
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
  5. leejones1981 thread starter macrumors newbie

    Joined:
    Dec 27, 2014
    #5
    I mean that the screen has the "connect to iTunes" logo and iTunes detects a device in recovery mode.
     
  6. a.borque macrumors newbie

    Joined:
    Dec 26, 2014
    #6
    Just to check some basics:

    There is enough space on your disk to download and prepare (extract, ...) the iOS-image?
    Are you running EMET?
    Have you tried to disable your antivirus-software?
    Are you using the same machine and the same user-account you formerly used for jailbreaking?
    If so, have you tried to use another machine or another account to restore?
    Have you checked which drivers Win uses to access the iPad?
     

Share This Page