updating java problems

Discussion in 'Mac Basics and Help' started by RedTurtle, May 10, 2009.

  1. RedTurtle macrumors newbie

    Joined:
    May 10, 2009
    #1
    I am brand new to Mac (I got a G4 laptop in trade to replace a dead windows desktop).

    I am trying to install Limewire and it tells me that I cannot: "could not launch application because it requires a version of Java that is not installed". It goes on to acknowledge that it can see everything up to 1.5...but that I need 1.6.

    So, I go to Software Update and make sure that I have 1.6. It tells me that there are no new updates, that my computer is up to date.

    I think I recall being told that I am running Leopard on this laptop.

    If java 1.6 is available, and I do not have it, and my computer tells me that there are no new updates that my computer needs and will not automatically grab java 1.6, yet I need it to install an application....what are my options?

    my thanks in advance
     
  2. Guiyon macrumors 6502a

    Joined:
    Mar 19, 2008
    Location:
    North Shore, MA
    #2
    What system are you running? I believe 10.5.4 or higher is required for Java 1.6. 10.4 can run up to java 1.5 and 10.3 can only use 1.4.2.
     
  3. Dave H macrumors 6502

    Dave H

    Joined:
    Mar 2, 2008
    Location:
    California
    #3
  4. RedTurtle thread starter macrumors newbie

    Joined:
    May 10, 2009
    #4
    Thanks guys

    I think I am running 10.4 (i'll have to check in a bit later when I can call the person I got this from). I guess I do not have an intel Mac (I had to d/l the PPC version of acrobat yesterday)

    Trying to work around not having 1.6, I tried to d/l Limewire 4.7, but I kept getting a response telling me that I cannot install it because I have a more recent version on my computer. I am confused about that, because (following instructions of a friend), I went to the HDD and dragged the existing copy of limewire into the trash (which i was told removes a file in full). So, in theory, there is no current version of it on my computer...does it hide somewhere else that I need to remove it from?
     

Share This Page