updating my ipod on old desktop

Discussion in 'iMac' started by thebends, Feb 3, 2014.

  1. thebends macrumors newbie

    Joined:
    Sep 8, 2009
    #1
    I'm running Mac os x version 10.5.8. Just bought a new ipod and its calling for os x version 10.6.8 I tried to update it, but it wont allow. keeps telling me that I have the latest version

    any help be great
     
  2. Marty62 macrumors 6502

    Joined:
    Mar 11, 2010
    Location:
    Berlin formerly London
    #2
    Hi,
    That's because 10.6( snow leopard ) is a paid upgrade !

    You can't go from 10.5 (Leopard) for free, and you have the latest 10.5 version.

    I don't know if Snow Leopard can still be bought at the apple store ?


    M.
     
  3. thebends thread starter macrumors newbie

    Joined:
    Sep 8, 2009

Share This Page