Updating to 2.2 (2G iPhone) Issues

Discussion in 'Jailbreaks and iOS Hacks' started by Joekage, Nov 22, 2008.

  1. Joekage macrumors newbie

    Joined:
    Nov 22, 2008
    #1
    Now I consider myself a pretty experienced person when it comes to unlocking and updating my iPhone 2G. But this has totally thrown me for a loop.


    I currently have a 2.1 2G iPhone, that is unlocked only, NOT jailbroken. I unlocked/jailbreaked it when 2.0 came out and gave up with jailbreaking just deciding to update and stick with the App store. This has worked out fine..until now...

    I updated, eagerly awaiting the 2.2 update but when the update was finished, I was greeted with a activation screen on iTunes much to my surprise.iTunes said that my SIM card was not supported or something.(I'm using T-Mobile by the way.) I then quickly searched google, and found a way to downgrade to 2.1 and used my backup to restore my iPhone back to it's previous settings.

    So I'm at a loss here, I just tried updating again and the same thing happened so I'm really frustrated. I appreciate any help you can give me. Thank you.
     
  2. pipanderson macrumors newbie

    Joined:
    May 8, 2008
    Location:
    Edinburgh
    #2
    Hi Joekage,

    Very interesting to hear it didn't work! There is another thread here where someone has updated their 2.1 2G with no issues! I was just about to upgrade myself until I read your thread.
    The only advice I can offer is to try updating WITHOUT any SIM card in the iPhone. I did this last time, as I use a Kuwait SIM card when travelling with work. My theory is that without any SIM card in the phone whilst updating, it can't complain that it is a "wrong" SIM card?!
    Only thing I can come up with. Interested to know how you get on.
     
  3. longmover macrumors member

    Joined:
    Apr 24, 2006
    Location:
    Wales, UK
    #3
    Hmm, I was just about to do this on my GF's 1st gen but not sure now! How hard is it to downgrade to 2.1 again?
     
  4. macbookhamburg macrumors regular

    Joined:
    Jan 3, 2007
    #4
    all worked great for me ... ! still activated... did you do a restore or update ?
    I updated thru itunes and everything is good ... with a restore it doesn´t work
    (bee using pwnage since 1.1.4)
     
  5. Joekage thread starter macrumors newbie

    Joined:
    Nov 22, 2008
    #5
    Yes, very interesting indeed. I'm not sure what's up... I mean, All I did was press the update button, did not restore or anything. Though I did minimize iTunes, letting it do it's own thing, so maybe something did happen that I wasn't aware of. After this whole fiasco, I had to restore back to 2.1, then had to use QuickPwn to reactivate the phone. So after getting my phone back to it's previous settings, I pressed the update button again and watched as iTunes updated my phone *took forever of course* Everything went smoothly, but at the end.. the same thing happened, causing me to restore and use Quickpwn once again.

    I'm baffled as to why this isn't working but unlike others, I'm not too impatient anymore to wait for the latest Quickpwn release. Just frustrated that it seems I can't upgrade easily like I've been accustomed to...
     
  6. seriouslyscrewd macrumors newbie

    Joined:
    Dec 2, 2008
    #6
    Joekage i need your help!



    I also have that same iphone, unlocked but not jailbreaked. I need to know how you downgraded it. I just want to restore it to how it was before i screwed it up with the update. What can i do?????
     

Share This Page