upgrade 3gs from 3.1.3 to 4.x.x

Discussion in 'Jailbreaks and iOS Hacks' started by wratran, Jan 28, 2011.

  1. wratran macrumors regular

    Joined:
    Nov 22, 2010
    #1
    Just bought a 3gs w 3.1.3 and 5.13 baseband. I unlock/jb already. I am on windows...dont have access to a MAC.

    I want to UPGRADE to 4.x.x firmware. TU and Cydia wont save any SHSH on this phone anymore...it only saves 4.2.1 and up.

    What are my option to get it to 4.x.x firmware without shsh blob? This is a firmware UPGRADE and not downgrade...so i was hoping it;s possible without shsh blob.
     
  2. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
    #2
    The SHSH tells the phone it's authorized. Doesn't matter if you're upgrading or downgrading.
     
  3. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #3
    are you saying i cant upgrade because there are no shsh on file?

    Can i do it thru custom firmware like sn0breeze...since i dont have a mac
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    If you dont have old SHSH files saved, you can only update / restore to the latest firmware, right now 4.2.1. With 3GS, depending if you have the old or new bootrom, the 4.2.1 JB will be untethered (can reboot normally) or tethered (require connected to computer to reboot). And, if you wish to keep your unlock, you should always update using a custom firmware (one that keeps your current baseband). Thus, in your case, you need a 4.2.1 custom firmware file.
     
  5. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #5
    thanks for the explanation...
    I thought i can use custom firmware create by snowbreeze...because i dont have a mac. Snowbreeze can do 4.1 custom FW.

    can i upgrade with this method?...or does it have to be 4.2.1 custom FW?
     
  6. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #6
    Even custom firmware still requires SHSH files to update / restore if it's not the latest firmware. Thus, for example, if you want to restore with official or custom 4.1, you need saved 4.1 SHSH files. And, since you don't have them, it won't work.
     
  7. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #7
    thank you
    I did not know that custom FW still require SHSH.
    So i am stuck on 3.1.3 (without SHSH) until untether JB is our for 4.2.1
     
  8. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #8
    If you have an old bootrom 3GS, you have a untethered 4.2.1 JB today. If new bootrom, you need to wait if you want untethered.
     
  9. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #9
    how can you tell the bootrom on 3gs?
    I just found this link from google search regarding using snowbreeze.

    http://thetechjournal.com/electroni...ndows-with-sn0wbreeze-1-6-1-expert-mode.xhtml

    It said if you start with 3.1.3 jb/unlock device, you can upgrade your FW. It left out remarks out shsh blob ....

    is this writing correct?
     
  10. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #10
    If you look at the date of the instructions, it's from June 2010 when 4.0 was the latest firmware. Thus, you don't need to mention SHSH files to update to latest firmware. Now, the latest is 4.2.1 so this instructions no longer apply.

    You can run forecast to tell what your bootrom is:
    http://ih8sn0w.com/index.php/products/view/f0recast.snow
     
  11. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #11
    what is the break off point for old bootrom....40 or less on the serial number?

    So Redsnow can do untethered JB on 3gs with old bootrom..is this correct?
     
  12. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #12
    Going by just the week number is not 100% correct. Instead, you need to look at the bootrom number. Forecast can tell you that. And, yes Redsnow can do untethered 4.2.1 JB with old bootrom, but you don't want to use it if you want to keep your unlock = baseband. To use Redsnow, you need to update to 4.2.1 which also updates the baseband to 5.1.5. Instead, you need to restore using a custom 4.2.1 firmware. Afterward, the phone should already be JB.
     
  13. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #13
    here is my phone info...is this the old bootrom? can i do untethered JB w/ redsnow?

    Serial Number : XXX37MR43NP

    Model : MB715LL
    Bootloader: 6.4

    I know that will lose baseband....im on ATT...
     
  14. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #14
    Where it says "Tethered?:," NO = old and Yes = new bootrom.
     
  15. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
    #15
    The tether box said "NO"...BUT it has 3.1.3 now...so it reading this FW and not the new 4.2.1....so would the tether box be accurate?

    I thought anything that is NOT MC serial number is old bootrom
     
  16. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #16
    No, it's not reading the FW. I should be reading the bootrom info, and thus, should be accurate. And, I believe MC serial number only applies to Ipod Touch.
     
  17. wratran thread starter macrumors regular

    Joined:
    Nov 22, 2010
  18. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #18

Share This Page