Upgrade 3GS to 4.0 Beta4

Discussion in 'Jailbreaks and iOS Hacks' started by phynios, Jun 16, 2010.

  1. phynios macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #1
    I'm trying to upgrade to iOS 4 Beta4 from 3.1.2 using iTunes on a PC, but every time I try I get an error message when iTunes tries to verify the update, error message 3014.

    I then googled this issue and was able to install HotspotShield which disguises my network traffic as though I'm using a different network. I'm not sure why this is useful in this scenario but it helped. (See http://blog.mcchouse.com/2009/08/iphone-os-301-update-error-3014.html)

    However now I am getting a message saying "the iPhone could not be restored. An unknown error occurred (13)". I am using Saurik's server address for gs.apple.com in my hosts file which I thought might be relevant here but it doesn't help.

    Any ideas?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Why don't you just wait till it is released to the public? My reasoning for it not working is that Apple is no longer signing beta 4 OR you are not a registered developer.
     
  3. phynios thread starter macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #3
    I just have a bit of time on my hands this week to play around with it. Next week I'm back to the old grind! :(

    I'm registered on Apple's dev network but only as a free member. I don't want 4.0 enough to fork out the $99/yr just to upgrade. I wouldn't get my moneys worth without a mac (for the dev tools) anyway I'd say.

    I just read that the GM version is available but I would need a Mac and iTunes 9.2 beta. Is there a way around this for PC users?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Without a Mac, you cannot upgrade to 4.0
     
  5. Apollo 13 macrumors 6502a

    Joined:
    May 29, 2010
    #5
    I thought it was because windows didn't have Itunes 9.2? My PC is telling me to download to 9.2
     
  6. phynios thread starter macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #6
    I just got that too, definitely wasn't there on Monday. I'll try it and come back.
     
  7. phynios thread starter macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #7
    That worked fine, looks like the GM 4.0 ipsw works fine with windows running iTunes 9.2. Now for the fun stuff....
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    I meant to type, you cannot upgrade and jailbreak iOS4 on a 3GS without a Mac as Pwnage Tool requires a Mac.

    Workaround: If you can find or have someone make you a custom restore IPSW, then you can use iTunes on your PC to install it.
     
  9. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #9
    I am running Windows 7 (64bit) and have a iPhone 3GS (32GB). I just downloaded iTunes 9.2 that came out today. However when I tried to restore the GM 4 ipsw it extracts the file then goes out to check the activation server and comes back with an error message...

    2010-06-17 01:12:50.531 [912:1424]: restore library built Jun 8 2010 at 18:17:31
    2010-06-17 01:12:50.531 [912:1424]: iTunes: iTunes 9.2.0.61
    2010-06-17 01:12:50.765 [912:1424]: iTunes: Current software version: 7E18
    2010-06-17 01:12:50.765 [912:1424]: iTunes: Software payload version: 8A293 (option key)
    2010-06-17 01:12:51.335 [912:144c]: iTunes: Specifying UOI boot image
    2010-06-17 01:12:51.360 [912:144c]: requested restore behavior: Erase
    2010-06-17 01:12:51.364 [912:144c]: amai: AMAuthInstallPlatformCreateDataFromFileURL: can't resolve file
    2010-06-17 01:12:51.580 [912:144c]: amai: tss_submit_job: invalid response
    2010-06-17 01:12:51.580 [912:144c]: amai: AMAuthInstallRequestSendSync: failed tss submission: Internal error
    2010-06-17 01:12:51.580 [912:144c]: amai: AMAuthInstallBundlePersonalizePartial: server request error: Internal error
    2010-06-17 01:12:51.581 [912:144c]: failed to personalize the restore bundle: Internal error
    2010-06-17 01:12:51.581 [912:144c]: AMRAuthInstallDeletePersonalizedBundle
    2010-06-17 01:12:51.592 [912:144c]: removed personalized bundle
    2010-06-17 01:12:51.650 [912:1424]: iTunes: Restore error 3014

    I guess I can wait for the official release but was just curious as to why I can't install it.
     
  10. ahfu25 macrumors 6502a

    Joined:
    Dec 28, 2009
    #10
    Yeah I get the same error message and I also have a windows7 64bit
     
  11. darkfiber macrumors 6502a

    darkfiber

    Joined:
    Jul 13, 2008
    Location:
    Columbus, OH USA
    #11
    As phynios mentioned about, maybe Apple isn't allowing installs of it anymore. If that's the case I can wait 4 more days I suppose. I am just anxious to play around with iOS 4.
     
  12. phynios thread starter macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #12
    I'm using windows 7 ultimate x64 too. One thing I did use was saurik's server address in my hosts file. Enter a line as below:

    74.208.10.249 gs.apple.com
     
  13. benflick macrumors 68020

    benflick

    Joined:
    Jul 11, 2008
    Location:
    Cincinnati, Ohio
    #13
    Keep trying to update by shift+restoring to the 4.0 GM. The first time it didn't work for me, today it worked fine.
     
  14. phynios thread starter macrumors member

    phynios

    Joined:
    Feb 10, 2010
    #14
    Just an update, it was actually iOS 4 GM that worked not beta4.

    I don't think you can click on 'Update', I think you have to use 'Restore'...

    I'm also having a few problems syncing. It's very intermittent but eventually each item syncs... annoying.
     

Share This Page