'Upgrade' and 'Archive and Install' Options not Available for Leopard install

Discussion in 'macOS' started by jonisign, Oct 28, 2007.

  1. jonisign macrumors regular

    Joined:
    Jul 7, 2007
    #1
    I'm currently trying to upgrade my machine from Tiger to Leopard and the install screen reports "You cannot install Mac OS X on this computer without changing your install setting." The only option available is to erase and install. Any advice as to why I can not perform an Upgrade or Archive and Install? My drive is partitioned as GUID, I have verified that there are no errors or unresolved dependencies with the disk utility, and Tiger is the first OS X install on the machine.
     
  2. AlexisV macrumors 68000

    AlexisV

    Joined:
    Mar 12, 2007
    Location:
    Manchester, UK
    #2
    Please give us some information. We can't work with you just telling us you have a 'machine'.
     
  3. confeos macrumors newbie

    Joined:
    Jan 25, 2007
    #3
    archive and install problem

    I had this same problem.

    I quit the install and rebooted into Tiger. Then I ran software update, macjanitor and permissions repair.

    then I went back to the install and it worked just fine. i didn't have to erase.

    i don't know what it was that actually changed it, but those were the steps I took.
     
  4. jonisign thread starter macrumors regular

    Joined:
    Jul 7, 2007
    #4
    It's a Macbook Pro, 2.33Ghz Core 2 Duo. My drive is partitioned correctly and the installer does not report that it needs to be repartitioned. Rather, the installer reports a yellow explanation point and says that OS X cannot boot from the volume, leaving erase and install as the only option. I'd prefer to do the Archive and Install than the Erase and Install... but with the GUID partition table set, the drive formatted correctly, and no disk errors, I am wondering what may have gone wrong.
     
  5. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #5
    Is your Tiger OS fully up do date (10.4.10)? If not, that is probably the problem. Run software update then try installing Leopard. Repairing permissions isn't a bad idea either.
     
  6. jonisign thread starter macrumors regular

    Joined:
    Jul 7, 2007
    #6
    Ah, thanks. I already tried the permissions and disk repair and they are both fine. I'll try the software update. Any specific task I should have macjanitor run?
     
  7. jonisign thread starter macrumors regular

    Joined:
    Jul 7, 2007
    #7
    Yup, it's at 10.4.10.
     
  8. jonisign thread starter macrumors regular

    Joined:
    Jul 7, 2007
    #8
    Alright, tried all the suggestions... no luck yet. Thanks for the effort!
     
  9. jpp22 macrumors newbie

    Joined:
    Oct 28, 2007
    #9
    I had the same problem, repaired the permissions and it worked. Before being able to repair the permissions however, I had to restore a copy of the /Library/Receipts folder, which I had emptied (Disk Utility was complaining with a "No Valid Package" error or something). I thought it was using too much space and didn't know that it was useful other than for keeping a history of your installs, which I didn't think I'd need.
     
  10. Gojulas895, Oct 28, 2007
    Last edited: Feb 1, 2012
  11. mashinhead macrumors 68020

    Joined:
    Oct 7, 2003
    #11
    i was considering reinstalling because i was having an issue with one program. and i also wanted to reinstall so i could uncheck the stuff i didn't need which i missed the first time (printer drivers, languages) that could save some space. will archive and install accomplish this?
     
  12. jonisign thread starter macrumors regular

    Joined:
    Jul 7, 2007
    #12
    Trying Again, still receiving Erase and Install as only option

    Alright, I'm trying to install leopard again and am still having issues getting "Update/Archive and install" options. Thanks to everyone who replied last month. I am still receiving "erase and install" as the only option. Here's what I have tried:

    - Repairing disk and permissions: this worked fine and there are no errors on the disk and permissions are okay.
    - Repairing disk and permissions with DiskWarrior: this worked and there are no errors on the disk, permissions are okay.
    - Mounting and Unmounting partitions from the command line and disk utility before selecting a drive to install OS X on: this had no affect on the install process.
    - Updating tiger to the latest, 10.4.11: no affect on install process
    - Verified '/Library/Receipts' folder was intact
    - Ran macjanitor before install attempt
    - Verified GUID partition table
    - Made sure no external drives or devices we mounted/attached to computer

    Any other suggestions? Everything appears to be normal before the install. The only other possibility I can think of is that I am using rEFIt to boot and I have 3 os partitions (os x, windows, linux).
     
  13. worldwearyeyes macrumors regular

    Joined:
    Mar 15, 2005
    #13
    Anyone else have this issue recently? Any tried & true solution?
     

Share This Page