Upgrade from 3.0 to 3.1.3?

Discussion in 'Jailbreaks and iOS Hacks' started by brguest, Mar 24, 2010.

  1. brguest macrumors member

    Joined:
    Sep 25, 2007
    #1
    I'm probably going to get some heat for this, but I never upgraded from 3.0. Everything was working so good, I just never went to the trouble of going to 3.1 and higher.
    Now, however, more and more apps that I need won't run on anything less than 3.1.2. I'm happy staying with AT&T so I don't need to unlock, but can I jailbreak on 3.1.3?
    Thanks!
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    If your on a 3Gs you can't jailbreak it without some work. If your of a 3G you can jailbreak it using Redsnow.
     
  3. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Because I'm guessing you have the old bootrom you can still jailbreak it. But unless you have the SHSH blobs for 3.0, 3.0.1, 3.1, and/or 3.1.2 if you have to restore the upgraded device you will not be able to jailbreak it for a long time, maybe never again. I'm not sure how to jailbreak 3.1.3 on a 3Gs. You'll have to wait for someone who does. I would hate to give you the wrong instructions then leave you with a broken iPhone.

    Edit: Go here for some info on this. http://blog.iphone-dev.org/post/376648600/pre-game-show
     
  5. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #5
    Can I just upgrade to 3.12 and jailbreak that? I don't think I need 3.1.3.

    What are blobs?
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    The SHSH blobs are Apple's latest thing against jailbreaking. Every time you upgrade or restore a iPhone 3Gs or iPod Touch 3G. iTunes asks some Apple servers if it can load the version of firmware you selected onto the device. If it is allowed Apple sends back a small signed blob of information that is unique to your device. All this happens in the background. If iTunes is trying to use a older version of firmware, like 3.0, Apple will not sign the blob for your device. Currently Apple will only sign 3.1.3. Because of this there is no way for you to go to 3.1.2.

    The maker of Cydia found out how to beat this system. He created a server that goes between your computer and Apple. It saves the blobs so that you can downgrade or use a version of firmware that Apple is no longer signing. If you open Cydia and on it's main screen it should say at the top "This device has a SHSH on file for firmware versions 3.x.x, 3.x.x" It will list the versions that are on file. If you ever clicked the "Make my life easier" button Cydia you should have some blob(s) on his servers.

    Here is more info about the SHSH blobs.
     
  7. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #7
    First, thanks for all your information and patience!

    Cydia says that I have SHSHs on file for 3.1, 3.1.2
    So does that mean I can go to 3.1.2? If so, how do I go about that?
     
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    Wow, consider yourself lucky. Are you on a Windowz box or a Mac?
     
  9. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    If your phone is currently jailbroken, you have old bootrom and can get into recovery mode, you can use iTunes to "restore" to custom restore 3.1.2 IPSW.

    This will bypass the security checks for 3GS.

    Use Pwnage Tool to make a custom restore 3.1.2 IPSW with 4.26.xx baseband so you can Ultrasn0w if you ever need it.
     
  10. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #10
    Note that if you are not currently jailbroken you can either jailbreak at 3.0 using redsn0w and then upgrade to the custom firmware, or (if you have access to a Mac) you can use make sure your iPhone is plugged in while you make your custom firmware and tell PwnageTool that your phone has never been pwned (PT will then pwn your bootloader so that you can restore to the custom firmware). Either way you should have no problem upgrading to 3.1.2 while preserving your very valuable 04.26.08 bootloader.
     
  11. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #11
    this is what I did to upgrade from 3.0 to 3.1.2.....all the apps needed 3.1.2 so I needed to upgrade....3.1.2 loads up soooo much faster too
     
  12. Apphooker macrumors newbie

    Joined:
    Mar 25, 2010
    #12
    hey guys, no specific answer? my girlfried want change her 3.0 to 3.1.3, i need the program or maybe chips you recommend:eek:

    Oh by the way, is it possible transfer 3g into 3gs? and how?
     
  13. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #13
    Mac
     
  14. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #14

    Great! Where do I get instructions how to do this? I don't want to screw up and I'm not confident on my own.
     
  15. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #15
    Use Pwnage Tool to make an custom restore 3.1.2 IPSW (iClarified has tutorials). Put phone into recovery mode then point iTunes at the custom restore IPSW
     
  16. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #16
    The iClarified tutorial says it will work with 3.1.3. I thought there wasn't a jailbreak on the last firmware?

    How do I tell if it is 4.26.xx baseband?
     
  17. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #17
    If your phone is on 3.0, it has 4.26.xx baseband.
    Custom restore IPSW's created with Pwnage Tool DO NOT update the baseband.

    Probably should have worded my initial reply in jailbreaking 101 vocabulary. Sorry.
     
  18. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #18
    Thank you!

    One last question before I do this. I use RedSn0w right?
     
  19. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #19
    You have missed the entire point of this thread.

    Where did I tell you to use Redsn0w ?

    I have already explained via my 2 or 3 replies exactly what you need to do.

    If you don't know how to use Pwnage Tool, go to iClarified for a tutorial.
     
  20. brguest thread starter macrumors member

    Joined:
    Sep 25, 2007
    #20
    iClarified has 32 tutorials - just wanted to make sure I picked the correct one to follow!


    * How to Jailbreak Your iPhone 3GS Using PwnageTool [Mac]
    Monday, 15th February 2010, 12:02 am
    Instructions on how to jailbreak your iPhone 3GS using PwnageTool for Mac. Updated for the latest 3.1.3 firmware.


    * How to Jailbreak Your iPhone 3G on OS 3.1.2 Using RedSn0w (Mac)
    Sunday, 31st January 2010, 06:01 pm
    Instructions on how to jailbreak your iPhone 3G on OS 3.1.2 firmware using RedSn0w for Mac
     
  21. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #21
    You asked how to go to 3.1.2. I have given you the name of the tool and the 3 requirements. Time for you to do sme reading

    Good luck
     

Share This Page