upgrade from 3.1.2 to 4.2.1 fromware

Discussion in 'Jailbreaks and iOS Hacks' started by zukin2956, Mar 20, 2011.

  1. zukin2956 macrumors newbie

    Joined:
    Feb 9, 2009
    #1
    have a 3gs with 3.1.2 to the latest firmware which can be jailbroken & unlocked.
    I downloaded 4.2.1 ispw file, tried doing the upgrade with itunes and i get the
    message that says it is not compatible.
    any ideas?

    thanks in advance.
     
  2. redhotline macrumors newbie

    Joined:
    Mar 19, 2011
    #2
    sure?

    do you sure you downloaded firmware for your model??
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    You need shsh blobs for 4.2.1
    Without them you can only update to the latest 4.3
    Open up cydia and look at the top of the page to see what shsh: you have listed there.
     
  4. zukin2956 thread starter macrumors newbie

    Joined:
    Feb 9, 2009
    #4
    where abouts on cydia do I get this info?
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    When you open cydia look at the top of the page. It should list the versions it has blobs saved for.
     

Share This Page