Upgrade from 4.3.3 to 5.0.1

Dasaco

macrumors newbie
Original poster
Mar 16, 2012
12
0
Hi all,

I can want to jailbreak my iphone 4 iOS 5.0.1. Now I have version 4.3.3 and firstly I have to update it to 5.0.1, only then jailbreak it. In iTunes i can't update it, because there is only newest version 5.1. I tried to find how to update it without iTunes and found that it is possible to update it through "Setting>General>Software update" in my iphone
but I have 4.3.3 version, to update it through settings I have to have iOs5.

Is there any other ways to update it without iTunes and "Software update" in iphone settings?

Thanks for help :)
 

Dasaco

macrumors newbie
Original poster
Mar 16, 2012
12
0
And if I put iphone in DFU mode and download 5.0.1 firmware, then Shift+Restore and select firmware 5.0.1 through iTunes? Maybe it will work? What do you think?
 

gngan

macrumors 68000
Jan 1, 2009
1,828
70
MacWorld
And if I put iphone in DFU mode and download 5.0.1 firmware, then Shift+Restore and select firmware 5.0.1 through iTunes? Maybe it will work? What do you think?
Maybe it won't work? It DEFINITELY won't work unless you have the 5.0.1 blobs and ap tickets which i doubt you have both.

It's not as simple as you think. You can't just download whatever firmware and restore it through DFU mode. Anything before iOS 5 can be install as long as you have the blobs saved. Anything after iOS 5 can only be install with blobs and ap ticket. That is with any A4 idevices. A5 devices like iPhone 4S, iPad 2 and the new iPad won't work.
 

Dasaco

macrumors newbie
Original poster
Mar 16, 2012
12
0
Maybe it won't work? It DEFINITELY won't work unless you have the 5.0.1 blobs and ap tickets which i doubt you have both.

It's not as simple as you think. You can't just download whatever firmware and restore it through DFU mode. Anything before iOS 5 can be install as long as you have the blobs saved. Anything after iOS 5 can only be install with blobs and ap ticket. That is with any A4 idevices. A5 devices like iPhone 4S, iPad 2 and the new iPad won't work.
I found Tethered 5.1 jailbreak, so I will wait for untethered then.
Thank you all for your answers :)