Upgrade from Panther to Leopard OSX

Discussion in 'macOS' started by buh, Sep 10, 2008.

  1. buh macrumors newbie

    Joined:
    Jun 19, 2008
    #1
    I have a MAC running OSX 10.3.9, with specs: Dual CPU G4 1.25Ghz + 1.75GB ram

    If I am going to upgrade OSX to Leopard 10.5 (not clean installation), is it possible to do? And if possible, will it give me trouble running applications previously installed on 10.3.9? such as conflicts... or do I need to upgrade the MAC machine to run Leopard?

    Any suggestions? Thanks in advance.
     
  2. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #2
    Hi, it shouldnt cause issue at all.

    I upgraded a PowerMac G5 1.8 Single CPU from i think 10.3.7 (maybe it was 10.2.7 Jaguar) or something like that to leopard 10.5.4 with out issue.

    You might also want to try an "archive & install" that way all the leopard stuff can be installed and the preferences and previous files of the panther install are still preserved.
     
  3. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #3
    My girlfriend's iBook 1.0 GHz / 1.25 MB RAM was upgraded from Panther to Leopard just fine.

    With regards to applications, all her Apple apps worked fine. The only other app that was added was Firefox 3. If you are taking about 3rd party apps, check the developer's site if Leopard is supported.
     
  4. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    You should be fine. The only problems are usually with very old software or non-retail. Most of which should have free upgrades available.

    TEG
     
  5. mikeminimac4now macrumors newbie

    Joined:
    Nov 16, 2008
    #5
    hi there, im new to macrumors forums and new to mac.
    ive just bought myself a second hand mac mini 1.25ghz powerpc g4 with 256mb ddr sdram running mac os x 10.3.9 just to see if i can get on with a mac before i buy a macbook or something similar.

    The reason ive bought the mac is because ive got an iphone and wanted to link the two together and ideally try to build an application on the mac to run on my iphone but as ive found out i need the latest os x 10.5.4 or .5 to run the sdk therefore my questions are these...

    1. can i upgrade from 10.3.9 panther to 10.5.4 or .5 leopard?
    2. what do i need for this, does it have to be done from a cd?
    3. will i need to upgrade my ram in the mini mac from the standard 256mb as i read on the apple website that minimum requirements are 512mb or is this abit overkill?

    many thanks in advance for any help,
    mike!
     

Share This Page