Upgrade to 3.1 on unlocked iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by frisbierecords, Sep 17, 2009.

  1. frisbierecords macrumors newbie

    Joined:
    Sep 17, 2009
    #1
    I've been searching for quite some time, but I am still confused.

    I am using an unlocked iPhone 3G v3.0.1. Jailbroke with redsn0w, unlocked with ultrasn0w. Do I need to jailbreak again with the new Pwnage Tool? If I do so, will I lose the unlock I already have?

    I am currently living in Europe, and if I lose my unlock, I'll be left with no phone, so I'd rather do this right the first time!

    Thanks!
     
  2. dZp macrumors 6502a

    dZp

    Joined:
    Mar 29, 2006
    #2
  3. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
    The process if you want to go to 3.1 is to build a custom ipsw with Pwnage tool on a Mac, to jailbreak the phone, and to install UltraSn0w from Cydia as you did before.

    You must not update the baseband, so do not let iTunes do the update to standard 3.1.

    This tutorial walks you through the process:
    http://www.iclarified.com/entry/index.php?enid=4254
     
  4. frisbierecords thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #4
    Hey..thanks for your help! That cleared things up, but I'm having some other trouble.

    The phone starts up with the pineapple, so I know I used the right custom restore file. In Cydia, ultrasnow was still there, so I didn't have to add it in again.

    Two problems: First, I am getting no signal even though the phone is accepting the sim (no logo, but I read that's typical).

    Second, I don't know how to restore my iPhone to my original backup before the pwnage with all of my apps, contacts, etc. Any thoughts?

    Thank you again (and in advance!)!

    Update: I am trying to restore again...just to see if maybe it was a fluke?
     
  5. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #5
    Your official apps, contacts, etc. are all on your computer. Just sync them back over. You will loose app-related info, like preferences and saved games.
     
  6. frisbierecords thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #6
    Yes! Thank you..the sync worked!

    So my only problem now is no signal. Any thoughts? It doesn't seem like the sim card was rejected (would it tell me if it was?).
     
  7. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #7
    If the SIM is rejected it should say 'No Carrier' but I've had this problem myself with 3.0.1 and also now on 3.1. I get just dots where the carrier power bars should be, can't dial out or in bu am able to surf using Edge but that's it...

    Toggle flight mode a few times and/or shut the phone down for a while. Try a SIM from another provider. Re-run the jailbreak
     
  8. frisbierecords thread starter macrumors newbie

    Joined:
    Sep 17, 2009
    #8
    Problem solved! So the issue was with my ultrasn0w. I went into Cydia>manage>sources>repo666.ultrasn0w.com and I installed it again (or updated, if that's what it was). When I restarted my phone, I was able to enter the pin code and get a signal. I hope this helps anyone who is having the same problem as I just did! Thanks everyone!!!!!!
     
  9. jdzialak macrumors regular

    Joined:
    Aug 14, 2008
    #9
    I used Pwnagetool to build a new ipsw and upgraded to 3.1 on my 2g running tmo.
    I was not JB'd anymore, since using 3.0.
    Worked great.
    Until I opened Cydia to get the MMS file. Pineapple screen from hell... couldnt DFU...Took hrs to get it back.

    I only did All this because I have nowhere that shows MMS settings on my cellular data settings page. I just wanted mms . I thought I need Cydia and 3.1 to get it.

    Joe
     

Share This Page