Upgrade to 4.1 using pwnage tool?

Discussion in 'Jailbreaks and iOS Hacks' started by gixxerfool, Sep 10, 2010.

  1. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #1
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    I don't think that pwnage tool support 4.1 yet ( I could be wrong), but if you want to update to 4.1 and keep your baseband here is a quick guide from TinyUmbrella. Now this won't keep your Jailbreake

    Get the latest TinyUmbrella (4.1.3)
    READ THE README TinyUmbrella README NOW Yes. You Read it.
    Run TinyUmbrella.
    Start TSS Server
    Open iTunes
    Restore 4.1 (NOT UPDATE) Yes this requires you to download 4.1 HERE
    Let iTunes error with 1004 error (baseband update failed - we want this :) )
    Kick Device Out of Recovery
    \o/ -- You are now on 4.1 with 1.59.00 baseband!

    Other guide:

    http://www.theapplepress.com/2010/09/08/iphone-4-1-upgrade-retain-original-baseband-unlock-tutorial/
     
  3. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #3
    There is no jb for 4.1. If there was it would be posted all over this forum.
     
  4. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #4
    My bad. I misunderstood what you were trying to do. Sorry.
     
  5. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #5
    I don't think he/she said anything about jailbreak, it was said that he/she wants to "preserve my baseband"
     
  6. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #6
    Pwnage tools have not been updated for 4.1 yet. A lot of confusion might be because the Dev team has the link to pwnage tool as 4.1 when it should be 4.01.
     
  7. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #7
    Actually there is a modified Hacked version of Pwnage tool that it can do that, and I think that is what the OP was asking, a quick search on google will yild it, however I don't recommend using it since who knows what exactly was modified, use only tool released by Dev team or (original Jailbreak developers).

    If all you want to is to keep the baseband them the TinyUmbrella way will cover you. If you want to jailbreak (which based on reports on twitter and google, it is possible on 4.1 with a 3GS using the old iBoot) do it at your own risk.
     
  8. gixxerfool thread starter macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #8
    Sorry guys. I should have been more clear. I am looking to maintain my JB And preserve my BB and move to 4.1 all at tha same time.

    Does there need to be a JB for the FW in order for pwnage tool to create a custom IPSW?
     
  9. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #9
    That you can't do. You'll have to wait for a jb for 4.1.
     
  10. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #10
    Pwnage tool hasen't been updated, I don't care what modified versions can do. I wouldn't recommend them to anybody. Until the dev team release an update, then the tools haven't been updated.
     
  11. gixxerfool thread starter macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #11
    Ok. Cool. I appreciate the swift reply. Thanks guys.
     
  12. Myzhi macrumors 6502a

    Myzhi

    Joined:
    Dec 15, 2009
    #12
    If OP came from 3.1.2, he/she doesn't have IP4. Thus, those instructions won't work.
     
  13. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #13
    Regardless of what you care or not, the OP question was if it was possible, and based on early reports it is with a 3GS+old iBoot+ modified pwnage tool.
     
  14. jcbauerca macrumors member

    jcbauerca

    Joined:
    Jun 4, 2008
    #14
    I tried it with my 3gs 4.01 BB 05.14.02 and it kept giving me a 1064 error so I am passing for now until the official one comes out.
     
  15. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #15
    Your attempts to contradict my posts are getting quite tiresome. No reason to quote me saying a google search will 'yild' a modified version, when they only thing I said was that the tools haven't been updated which they haven't. It's clear he is asking for opinions about doing it this way and there is no way in good faith that I could recommend it. I'm not here to give anyone a bad experience in the JB scene by recommending something that in all likelihood could screw up the install.

    No, he/she said he wanted to update with pwnage to 4.1 which leads one to believe that he/she wants to be jailbroken also. The only reason to preserve the baseband is to unlock, which last time I check required a jailbreak.
     
  16. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #16
    it doesn't lead "one" to believe anything, it lead YOU to believe. AS i said using the modified pwnage tool you can keep your jailbreak on the 3GS with old iBoot (I just tried myself on my development phone, works perfect). I wasn't trying to contradict your post, matter of fact i was trying to ignore your narrow view of everything and give the OP the best response without confusing him/her.

    and no it is not the "ONLY" reason, I have lost my Jailbrake on 3GS many times but keep my old baseband just in case i want to test an unlock later. so Wanting to upgrade to a new firmware and keeping the old baseband doesn't mean keep jailbreake. (unless you always see everything in absolute with such a narrow view of the world)
     
  17. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #17
    It is not wise to recommend hacked versions of PwnageTool. The Dev-Team will surely have a release for us soon, one that's been tested and will be far less likely to cause problems down the road.
     
  18. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #18
    I’ve got to admit, I’ve seen some of the most impatient people on these forums.
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    You gotta wait like everyone else.
    There is no JB available yet.

    I hear you.
     
  20. gixxerfool thread starter macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #20
    My posting wasn't about impatience. I did a quick google search and found the Instructions I posted in my OP then searched here for verification and didn't find anything. I didn't know if these would work. I was only checking to see if I missed something on a possible upgrade to 4.1. Nothing more.
     
  21. ifonz macrumors newbie

    Joined:
    Jun 25, 2009
    #21
    not quite working yet though. if i put my att sim in, the phone freaks out. and safari doesn't work.
     

    Attached Files:

Share This Page