Upgrade to 5,1 -- Can I use my old software?

Discussion in 'Mac Pro' started by syrinxfilms, Sep 2, 2015.

  1. syrinxfilms macrumors newbie

    syrinxfilms

    Joined:
    Aug 12, 2010
    Location:
    Southern Cali
    #1
    I am FINALLY looking to upgrade my workhorse 2006 Mac Pro 1,1 2.66 Quad Core. A spritely 2010, 3,33 6 Core machine has caught my eye. (I want to stay in the OSkool Tower family) But I have some legacy software I need to keep using that is set up on OSx 10.6.8. Can I run 10.6.8 on the 5,1 machine? And will there be a problem with the Nvidia GTX680 2GB Video Card that I am looking at? If the 5,1 is okay but the Video card isn't, what are my options? (ATI 5779? 5870? Other?)

    Are there other issues I should look out for? And is this a good idea? Thanks,

    Jeff
     
  2. Fl0r!an macrumors 6502a

    Joined:
    Aug 14, 2007
    #2
    2010 MacPro have 10.6 as minimum OS, 2012s require at least 10.7.4: Source
    A GTX 680 requires at least Mountain Lion. The latest video card options for 10.6.8 are HD 5xxx generation and (as far as I know) GTX 4xxx Fermi cards.
     
  3. syrinxfilms thread starter macrumors newbie

    syrinxfilms

    Joined:
    Aug 12, 2010
    Location:
    Southern Cali
    #3
    Thanks, that helps.
     
  4. syrinxfilms thread starter macrumors newbie

    syrinxfilms

    Joined:
    Aug 12, 2010
    Location:
    Southern Cali
    #4
    BTW could I substitute in one of my old cards? (ancient/original nVidia 256K and flashed (but sometimes problematic) ATI 4890 1 GB? Or should I simply look for a system with a 5770 or better yet 5870? It sounds like if I had that and a 2010 5,1 I could use both old and new software, correct?

    Thanks.
     
  5. Fl0r!an macrumors 6502a

    Joined:
    Aug 14, 2007
    #5
    If I recall correctly, the HD 4890 needs a patched kext to work, which would be a no-go for modern OS (esp. Yosemite and El Capitan). I guess the Nvidia you're talking about is a 7300GT? The EFI on this card won't work in a 5,1, so it won't be usable in 10.6.8. This card also doesn't have any 64bit drivers, so a modern OS won't work either.

    HD 5xxx will work from 10.6.x up to El Capitan. Doesn't matter if genuine one from Apple or flashed.
     
  6. ssls6 macrumors 6502a

    ssls6

    Joined:
    Feb 7, 2013
    #6
    You can run 10.6.8 on a real MP5,1 but you can't install from the official 10.6.3 DVD. The DVD will check the MP model number against the list that it can install to and fail. So, if you pull the drive from your old MP and slip it into the new MP, it should work fine.

    You can't use a GTX680 with 10.6.8 but you can use a ATI5770 and probably the ATI5870. I have personally put a snow leopard drive in my real MP5,1 along with a ATI5770 and it worked great. Make clones of your working installation as DVD reinstalls will never be an option. Clone installs are just fine.

    Finally, I started using snow leopard in a parallels VM instead of booting it natively which met my needs and allowed me to upgrade my MP5,1 to yosemite and start using my GTX680.
     
  7. flowrider, Sep 3, 2015
    Last edited: Sep 3, 2015

Share This Page