Upgrade to jailbroken 2.2.1 help

Discussion in 'Jailbreaks and iOS Hacks' started by brentoniscool, Feb 7, 2009.

  1. brentoniscool macrumors newbie

    Joined:
    Jan 30, 2009
    #1
    Ok I Upgraded to the official 2.2.1 upgrade from apple. I'm using Pwnage Tool. I'm running a Black Macbook with 10.5.6 but I did do the download to enable DFU mode. So I've already downloaded and made the custom firmware 2.2.1 and i'm trying to install it on my phone but after itunes extracts the file I get the error message, "The iPhone "iPhone" could not restore. An unknown error occurred (21)." Can someone please help me?
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Which download did you try? The one from the Dev Team blog?

    You may need to try a powered USB hub which seems to work for pretty much everyone.
     
  3. candychunk macrumors member

    Joined:
    Nov 5, 2007
    Location:
    Cali
    #3
    I too have the same situation, I've tried it so many times... restarted, re-downloaded, restore, etc... still not working... keeps giving me that error 21 :(

    i dont have a usb hub so i cant try that...
     

Share This Page