Upgrade to mavericks, AFP not working now.

Discussion in 'OS X Mavericks (10.9)' started by ebt, Oct 4, 2014.

  1. ebt macrumors newbie

    Joined:
    Jan 19, 2011
    #1
    So, I've finally bit the bullet and gone from good old realiable snow leopard to mavericks.

    After the update, my connection to my NAS (plextor unit, supports afp) no longer works.

    I've been trying out the various help guides online, but still no joy (finder has the "version of the server you are trying to connect to is not supported" dialogue).

    Following the official apple guide at http://support.apple.com/kb/HT200160?viewlocale=en_US, craps out at step 4. basically i just cant seem to connect at all.

    Using the NAS's web interface I've created a test ID to try to eliminate that, but thats still the same issue.

    Does anyone have a solution for connecting to AFP (please dont do the 'use a different protocol' reply).
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Mavericks changed the way AFP works and you will likely need a firmware update for your NAS to accommodate this. This was a pretty common issue when Mavericks first came out.
     
  3. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #3
    Search around for similar issues on other brands of NAS gear. There might be a permissions fix.
     
  4. ebt thread starter macrumors newbie

    Joined:
    Jan 19, 2011
    #4
    Its an old nas. Seems to me if apples update breaks functionality, I should be able to fix it on the Mac.....
     
  5. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #5
    You'll just have to update the firmware of the NAS in order to make it compatible with Mavericks.
     
  6. cjmillsnun macrumors 68020

    Joined:
    Aug 28, 2009
    #6
  7. ebt, Oct 5, 2014
    Last edited: Oct 5, 2014

    ebt thread starter macrumors newbie

    Joined:
    Jan 19, 2011
    #7
    :) as you can see in post 1, that guide didnt work.

    Firmware update isnt an option either.... its an old NAS. I suspect the easier answer here is just to reinstall snow leopard, but it seems a bit crazy that an OS upgrade renders a vendors own protocol unusable.
     
  8. NathanA macrumors 6502a

    Joined:
    Feb 9, 2008
    #8
    You say it "craps out at step 4," but you didn't say how. (Error messages, blank response, locks up, etc.)

    More details are always helpful.

    At no point in any of those steps in the Apple article are you talking to a server. You are simply interrogating the AFP settings on your computer, and at step 5 you will be making a settings change.

    So if it is "crapping out" when you say it is, then that would seem to suggest there is a problem with your installation of Mavericks.

    In the "Learn More" section, it suggests that it is safe to delete the /Library/Preferences/com.apple.AppleShareClient file that contains the settings in question, and that in the absence of such a file, the OS will rebuild the file using the default settings. Perhaps if you cannot read that file in step 4, the problem is that the file is corrupt? Try deleting that file, then rebooting your computer, and then run through the steps in that Apple document again.

    -- Nathan
     
  9. ebt, Oct 8, 2014
    Last edited: Oct 8, 2014

    ebt thread starter macrumors newbie

    Joined:
    Jan 19, 2011
    #9
    Hi Nathan,

    My understanding of the process was that you had to attempt a connection, so that the OS would create that disabled uams parameter list....and then you write to the list to remove those exclusions.

    Anyway, it might be quicker to include some screenshots.

    Mavericks Install: Connection attempt after populating the uams list

    [​IMG]

    Mavericks Install: Connection attempt after running commands to remove disabled uams.

    [​IMG]

    Mavericks Install: Connection using a snow leopard virtual machine in virtualbox.

    [​IMG]

    This would be great, if only virtualbox had support for USB ports in an OSX VM. It works and i can see the files, but without the ability to migrate them onto another USB drive Im a bit stuffed.

    Any insight would be welcome...

    ps. using "open afp://.....etc" on mavericks just gets the dialogue that it cant connect to this version etc.
    pps.the nas supports multiple accounts anonymous/guest and many others including testid. I've tried numerous permutations but havent put *all* the screenshots up since i was just trying to eliminate any login conflict on the nas itself. all of the accounts work when used with the SL VM.
     

Share This Page