Upgrade to Snow Leopard causing inability to connect wifi via PHY Mode 802.11n

Discussion in 'MacBook' started by arenot biggot, Nov 23, 2011.

  1. arenot biggot macrumors newbie

    Joined:
    Nov 23, 2011
    #1
    Hello,

    I have a macbook that I bought in South Korea about 4 years ago. I am now in Canada trying to connect to my school's wifi. Prior to this I was running 10.4 and I was having no trouble connecting to this network. Upon upgrading, I was given a "connection timeout" message whenever trying to connect. In the meantime, I have had no trouble connecting to other wireless networks.

    I have tried a variety of things:
    - changing the order so that wifi is first to connect
    - rebooting PRAM
    - upgrading to lion, then fully updating all lion software
    - logging in to the network with other user names
    - going to guys who run the network and double checking that neither my user name, nor my computer's id has been banned from network.

    After spending far too much time researching this, I have come to the conclusion that maybe my country code has something to do with this. When I go into the detailed "about this mac" page and look at my wifi I see that supported PHY Modes are 802.11 a/b/g. I also notice below that my school's network is 802.11 n.

    I think this is my problem. Somehow, in formatting my computer and upgrading my OS I lost the ability to connect to 802.11 n networks. Does it sound like I am on the right track? Is there any sort of firmware, upgrade, update, fiddling I can do in order to get my airport back on this network?

    I wouldn't really care, but I need wireless connectivity to write my exams.

    Any help greatly appreciated!
     
  2. arenot biggot thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #2
    As a further update, I have found a 802.11n Enabler for $2.50 from the app store. I quickly purchased said enabler, then tried to install it. To my dismay it only works with 10.45.

    I think I might be SOL and there might be no available method to enable my old macbook to get onto this network, which is eminently frustrating because on the older OS it had no trouble.
     
  3. nicklad macrumors 6502

    Joined:
    Jun 13, 2007
    Location:
    Nottingham, UK
    #3
    Which model of MacBook do you have? It's far more likely that it doesn't have the necessary hardware...

    If that's the case, you'll only be able to connect to networks that allow legacy 802.11g clients to connect unless you change the wireless card inside the laptop, or replace the laptop.
     
  4. arenot biggot thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #4
    It an old 2ghz intel dual core.

    I can't figure out exactly what wifi card I have from system profiler, it just says "Airport Extreme".

    The only reason I am fighting this so hard is because it wasn't an issue before upgrading to snow leopard. I must have had some sort of software or driver or something that was allowing me access to this very same network before the upgrade.

    Is there no way I can find and then reinstall whatever this was?

    Thank you for taking the time to respond.
     
  5. arenot biggot thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #5
    Alright, so after a little further research, I have found out that this really is just a general problem with macbooks purchased in South Korea during 2006. For some reason, after upgrading to Snow Leopard (AND Lion apparently), the wireless cards in them simply stop being able to connect to 802.11n networks.

    This is confirmed by these posts:
    https://discussions.apple.com/thread/2343656?start=0&tstart=0

    No solution seems to exist, so maybe I will just dial it back to Leopard.
     
  6. adamtj11 macrumors 6502

    Joined:
    Feb 26, 2011
    Location:
    Belfast
    #6
    if its core duo it won't run and there is your problem
     
  7. arenot biggot thread starter macrumors newbie

    Joined:
    Nov 23, 2011
    #7
    Not true. I have now dialed it back to Leopard and I am writing this reply from the network I couldn't get on to earlier.
     

Share This Page