Upgraded 4,1 to 5,1 with x5690 now loud beep under load

Discussion in 'Mac Pro' started by kiwirob, May 2, 2018.

  1. kiwirob macrumors newbie

    Joined:
    Jul 7, 2010
    #1
    Hi,

    I've gone through the upgrade process and installed 2x delidded x5690 CPU's and everything runs pretty good until the machine is a few minutes into heavy load.

    Running 10.11 El Capitain.

    Over ~= 65%+ for a few minutes there is a solid beep that stays until the load is taken down below ~=50%

    Also when awaking from Sleep the machine will also beep when it is under load when put asleep (but not necessarily beeping).

    I have installed Macs Fan Control and none of the CPU temps are that high. I can get the error to occur with the CPU A Diode Temp below 75ºC (167ºF) with load at 100%. I'm using "yes > /dev/null &" for load and 12 processes is about 50%, 24x is 100%. if I Killall Yes processes the noise instantly goes away and if I kill each one at a time the noise goes away when I'm down to about 10 or 11 Yes processes running.

    I have also reset PRAM and thank my SMC reset worked fine too.

    Have checked console logs to try find an error message for the noise but can't find anything.

    Any suggestions on where I might be able to track down the cause of the error?

    Thanks

    Kiwirob
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    Did you try reseat the CPU?
     
  3. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    I don't know off hand.

    I would think it is in the logs and that you were on the right track, but it could be non-obvious and hard to find. A strategy to narrow it down would be to keep a system clock up on your desktop. When the beep happens, look at the time including the second. That way you can look at the logs again but narrow it down to a window of events that occurred within a few seconds of that time.

    If there is still nothing in the logs, I wonder if there is a beep alarm happening automatically in the firmware of the logic board, so the OS doesn't know about it and doesn't log it. You could look for audible alarms in the service manual PDF.
     
  4. bsbeamer macrumors 68000

    Joined:
    Sep 19, 2012
    #4
    If this is NOT an install issue that is fixed by re-installing the processor (and cleaning the board/socket), these details might help:

    what build/version of El Cap?
    any chance you've recently installed a security update?
    what firmware/Boot ROM Version are you running?
     
  5. kiwirob thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #5
    Yes I did reseating the CPU with no luck.

    So with the processors when I removed the original heatsinks the original quad xeon processors had a black plastic spacer guard around them that was the same size as the delidded cpu sicks above the pcb. I decided to use them because they should help stop over tightening the heatsink and causing damage.

    Update:

    So I have just swapped out the processor tray and installed it in a genuine 5,1 and everything booted up fine but the same long beep sound when the processors were put under load.

    I think this narrows the issue down the processor tray and/or one or both x5690 CPU's.

    I also when through the long process of installing the Apple Diagnostic into /System/Library/CoreServices/.diagnostic so I could do the hardware check (on the upgraded cMP 4,1) and everything passed with flying colours.

    Can I run a dual processor board with a single processor? I might be able to determine if it's one of the x5690's thats causing the problem.
     
  6. ActionableMango macrumors G3

    ActionableMango

    Joined:
    Sep 21, 2010
    #6
    Yes. The fans will run full blast, but other than that it will work.
     
  7. orph macrumors 68000

    orph

    Joined:
    Dec 12, 2005
    Location:
    UK
    #7
    wait are you using a macpro 5.1 tray in a macpro 4.1?

    edit
    yes you can boot with just one cpu, it's one of the default testes to do after a dual cpu upgrade (people used to over/under tighten 4.1 and lose ram slots etc)

    if you use a 5.1 tray in a 4.1 (or vice versa) the fans will operate at full blast, so as long as you have a 4.1 with a 4.1 tray it's ok (even a 4.1 with 5.1 firmware will need a 4.1 tray)
     
  8. kiwirob thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #8

    I went down the rabbit hole of upgrading to High Sierra so I could get the firmware upgrade.

    No I'm sitting on OSx 10.13.4
    Boot ROm Version: MP5,10085.B00
    SMC Version (System) 1.39f5
    SMC Version (Processor Tray) 1.39f5

    All security up dates are updated

    I have included a couple screen shots from Macs Fan Control and iStat Menu's that were taken with the CPU's under load and beep happening.
    --- Post Merged, May 3, 2018 ---
    The first 3 screenshots where taken when the long beep was occurring, the next 3 were taken after the CPU load was reduced and the beep stopped. Very little difference in temperatures etc...
     

    Attached Files:

  9. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #9
    All temperature looks normal indeed. However, I suspect you use the WRONG reference temperature for MacsFanControl (even though this should has nothing to do with your problem).

    IMO, you better use the CPU Diode temperature, but not the "from PCECI" temperature.

    And I also suggest to only install a single CPU into socket A for diagnosis purpose. Just in case one of the CPU is bad.
     
  10. kiwirob, May 3, 2018
    Last edited: May 3, 2018

    kiwirob thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #10
    So to update my diagnostics on this.

    Removed Processor B and ran up system with only Processor A in => No Problem
    Swapped ram from Proc B into Proc A slots => No Problem
    Installed Proc B into Proc A (swapped processors) => No Problem
    Reinstalled Original Proc A in Proc B socket => loud constant beep after 2-3 mins 100% load

    In every case the CPU diode temps never went over 65ºC

    Im wondering if it's a problem then with either the PSU not liking the additional 130W from the 2nd x5690 processor or if the issue is with the 2nd Processor socket??

    Also interesting that the fault can be instigated upon waking from sleep mode when put to sleep under 100% load. This has me thinking its possibly power related also.
     
  11. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #11
    The PSU is rated 980W, and so many members running dual X5690 for years now without any issue. So, power should not be the issue. Especially if the issue can be fix by swapping CPU, then obviously it's not power related.

    And if you can fix that by swapping processor. Then better just swap it, use it, and forget about the beep.
     
  12. bsbeamer macrumors 68000

    Joined:
    Sep 19, 2012
    #12
    I'm running 2 x 3.46GHz (X5690) with 128GB RAM and a GTX 1080 FE (rated at 180W). PCIe slots are fully loaded with cards. SATA bays are fully loaded with SSDs. Have not seen my UPS display creep much above 600W when rendering with CUDA enabled software (GPU taxing). When not taxing the system, it's typically around 250W for normal operations with multiple apps open.

    Have worked on many client machines with similar configurations in the past few years and I've never seen the system draw more than 750W on those with a digital display UPS. (I'm sure it's happened to some people.)

    Unless your PSU is bad, the PSU is not the causing the issue. Your GPU "MIGHT" be contributing if it's underpowered, not evenly distributed, or not properly connected, but does not sounds like that is the case. Seems like an issue with your CPU install or the board itself. Check the daughter board connection and clean the connection on both sides. Check that there isn't a stray piece of hair or any dust near the CPUs that could be contributing to overheating. If you are not connected via UPS (battery backup) get a power meter, check your source power to see if it's spiking low/high.
     
  13. kiwirob thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #13
    ok further progress update

    I have another genuine 5,1 running 10.12.6 but flashed with the High Serria firmware update

    Boot Rom MP51.0085.B00
    SMC Version (System) 1.39f11
    SMC Version (Processor Tray) 1.39f11

    And I also have another set of x5690's

    So I put both x5690's with their lids on in the cMP 5,1 => under load same continuous long error beep as with the flashed 4,1
    I used a new x5690 with one of the 4,1 5690's in the 5,1 => under load same continuous long error beep
    I swapped out the 4,1 5690 with the other one => under load same continuous long error beep
    I put in the 2nd new 5690 in the 5,1, so two new cpu's => under load same continuous long error beep

    While the error beep is happening the systems are fully responsive, there is no crash, kernel panics, or logs that I have found. I reduce the load the a beep goes away.

    This is starting to get very weird. If the processors were faulty I'd expect to see some panic or the system to freeze, but nothing, just a long continuous beep until I reduce the load below 50%. The 4,1 ran for close to an hour earlier today before the dreaded beep started and I was starting to think the problem might have sorted itself out.
     
  14. bsbeamer macrumors 68000

    Joined:
    Sep 19, 2012
    #14
    what else is connected to your system?
    what is in PCIe slots?
     
  15. kiwirob thread starter macrumors newbie

    Joined:
    Jul 7, 2010
    #15
    I'm not connecting to a UPS currently.

    I do happen to have a internet over power system in my house connected. Perhaps that is messing up the power, but I have other computers also connected and no problems.
    --- Post Merged, May 3, 2018 ---
    4,1 has an Apple ATI Radeon 4870 (I think from memory it's not currently got CPU's in it)
    5,1 has an Apple ATI Radeon 5870

    So nothing else fancy in there
     

Share This Page