upgraded iphong 2g to 3.0 firmware using beta 5 now network doesnt work.

Discussion in 'iPhone' started by mraloteibi, Jun 2, 2009.

  1. mraloteibi macrumors newbie

    Joined:
    Jun 2, 2009
    #1
    i upgraded my iphone 2g to the 3.0 firmware using beta 5 everything worked perfectly and everything on my iphone works even the wifi but when i put my t-mobile sim card it just shows that i have no service and i cant make calls or texts or recieve them. i even tried putting in my moms at&t sim card and the same thing happened what do i do to fix this and get service? also when i go to settings general settings and about my network says not available. how do i make the simcard network work? thanks.
     
  2. abarna21 macrumors regular

    Joined:
    Mar 30, 2009
  3. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #3
    Umm.. why would you upgrade to 3.0 if your phone is unlocked? The reason it isn't working is because the unlock is now gone, because you updated to the new OS. It erased the jailbreak/unlock. You need to downgrade back to 2.2.1 and rejailbreak and reunlock. To jailbreak/unlock the device you can follow our guide here.
     
  4. Diode macrumors 68020

    Diode

    Joined:
    Apr 15, 2004
    Location:
    Washington DC
    #4
    That's for the 3G ... he has a 2G
     
  5. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #5
    It can still erase the unlock on the device, it doesn't matter what version it is. Especially with an update like 3.0 which is a major update, it probably reflashed the phone and relocked the baseband.
     

Share This Page