Upgraded memory on MBP, now its making weird sounds/wont bootup

Discussion in 'MacBook Pro' started by tman08, Mar 3, 2008.

  1. tman08 macrumors member

    Joined:
    Feb 26, 2008
    #1
    I just installed new memory in my macbook pro (2.4 penryn if it matters). I know its the right memory and whatever Muskin (2x2gb). It was easy enough, I followed all of the instructions and was done it like 3 minutes. When I tried to start the POS up it made these loud beeping sounds like an alarm and the sleep indicator thing on the latch kept beeping. Well, I knew that wasn't good I so had to remove the battery to get the thing to stop making that horrible sound. I then proceded to put the original memory back in and give it a try. The same thing happened. So now this damn thing won't work at all. Does anyone know what the hell just happened. How do I so called easy upgrade go so damn wrong. I'm guessing I'm going to have to take this thing to the genius bar, which sucks cause I hate going in that horrible apple store.:mad:
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    Make sure the RAM is installed properly, you have to push it in alot harder than you'd imagine you should.
     
  3. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #3
    To amplify ^, the MBP uses a RAM socket that you have to insert the RAM at a 45 degree angle. You need to get both thumbs onto the RAM and firmly push th contacts into the socket WHILE it is still up on the 45 degree angle. Then lay it down to the horizontal position. There should be none, or very little (<1mm), of the gold contacts remaining visible if itis installed correctly.

    The clips ;clicking; into place is NOT an indicator that it is correctly installed.
     
  4. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #4
    If the memory is seated correctly and it still doesn't work, try putting the old memory back in. If that works correctly, try installing one new chip at a time as you might have a faulty RAM chip.
     
  5. tman08 thread starter macrumors member

    Joined:
    Feb 26, 2008
    #5
    Yeah I checked that out. Both cards are properly inserted into the slots.
     
  6. tman08 thread starter macrumors member

    Joined:
    Feb 26, 2008
    #6
    Yeah, it's actually a 25 degree angle. I made sure I barely saw any of the gold connection strip (just as its indicated on in the instuction booklet). I tried again with the old RAM to make sure it was inserted correctly and it is buts it still doing the same thing. So, does the sound mean that something is not installed correctly?
     
  7. Viper2005 macrumors 6502

    Viper2005

    Joined:
    Dec 2, 2007
    Location:
    Canada
    #7
    The worst case scenario would be that you might have damaged the mainboard during the install. Did you ground yourself properly?
     
  8. RayS macrumors newbie

    Joined:
    Dec 23, 2008
    #8
    got it fixed?

    Hi, I am having the same problem ..........although in my case I had the upgraded ram in the MBP working fine for two months........removed the top 2gb and all is fine .................???just wondering if you got it fixed etc....

    thanks

    Ray
     

Share This Page