Upgraded server remotely from Mavericks to Yosemite...

Discussion in 'OS X Yosemite (10.10)' started by jimmyco2008, Oct 13, 2014.

  1. jimmyco2008 macrumors regular

    Joined:
    Jan 8, 2014
    #1
    Hey all,

    Earlier today, I used Screen Sharing to remote into my Mac server (hundreds of miles away), and started the Yosemite upgrade process.

    I can SSH into it, however I can not get in through Screen Sharing.

    I'm told the Mac is booted up, at the login screen, prompting for a bluetooth keyboard (which is stowed away because I'm not there...)... So Yosemite was installed successfully and will boot.

    I have all the power of SSH, however the only commands I can find for enabling Screen Sharing are for 10.8 at best... I've tried a few (of course there're like 5 commands for everything), and none have proven successful.

    For what it's worth, I had OS X Server on it, and it was managing "everything", including file sharing and remote management. Obviously Server is no longer on this Mac since it's on Yosemite now....

    AFP works, I can remotely mount my home folder.

    Any ideas on restoring Screen Sharing?
     
  2. jimmyco2008 thread starter macrumors regular

    Joined:
    Jan 8, 2014
    #2
    Nevermind....

    I used this command:

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -clientopts -setvnclegacy -vnclegacy yes -clientopts -setvncpw -vncpw mypasswd -restart -agent -privs -all

    and opened all ports on the router there and forwarded them all (1 - 65535) to the local IP of the server... And viola! I had tried that above command multiple times before forwarding all the ports, so I think it was the port forwarding that did it... Which is odd, considering I was forwarding 5900 already.

    Of course one should never keep ports open like that, it's merely so I can "fix" the Server setup!
     
  3. gwaereth macrumors newbie

    gwaereth

    Joined:
    Apr 23, 2003
    Location:
    Chicago, IL
    #3
    Port?

    Hey Jimmy,

    Curious is you discovered any port settings that are unique to Yosemite Screen Sharing?

    I can connect to my Mac Mini, now running Yosemite, via Screen Sharing by hitting the IP directly.

    However, when I try and hit the machine via it's public URL (and thus through the router port forwarding) I cannot.

    Any help or guidance would be appreciated.

    Thanks!
    Sam
     

Share This Page