Upgraded to 4.1gm, now no 3G data?

Discussion in 'iPhone' started by parker770, Sep 3, 2010.

  1. parker770 macrumors member

    Joined:
    Apr 5, 2010
    #1
    Well, I went ahead and dl'd 4.1gm, and installed it. Everything went smoothly, until I noticed that 3G data had stopped working.

    The phone was jailbroken on 4.0.1 before, and I knew I would lose the jailbreak, but didnt think there would be problems with data.

    I have tried resetting network connections, and restoring from backup, nothing seems to work.

    All I have not done yet is to restore it as a new device, simply because I don't want to loose all of my data.

    Any ideas?
     
  2. parker770 thread starter macrumors member

    Joined:
    Apr 5, 2010
    #2
    Crisis averted, and I didn't have to restore as a new device:D

    I restored again from backup, and turned off the cellular data, then reset network settings and rebooted. Once back up, I switched cell data back on, but left 3G off. I was able to connect over EDGE, then I switched 3G back on and it magically worked.

    Very strange.

    If anyone has similar problems, try the above.
     

Share This Page