Upgraded to Snow Leopard; can't connect to router or any wireless network

Discussion in 'macOS' started by ktor84, Feb 8, 2010.

  1. ktor84 macrumors newbie

    Joined:
    Feb 8, 2010
    #1
    After extensive Googling, I need to take a break, and find out if someone with more experience knows what I can try next...

    I'm not the best when it comes to Networks, or even router configuration. I'll just put that out there, in case I've missed something obvious.

    My router connection (DLink 2640B) was working perfectly fine before I upgraded to Snow Leopard. Now I cannot connect to any wireless network, and I cannot connect to the router administration page, either (192.168.1.1).
    The internet connection still works fine on two other laptops. Also, I can connect this iMac via the ethernet cable.

    I've tried deleting the files NetworkInterfaces.plist, com.apple.network.identification.plist, and preferences.plist; I've tried rebooting my router; I've tried creating a new network. Airport sees all the networks, tries to connect, then it just says that it fails.

    If anyone has any advice, I would be so so happy.

    Thanks so much.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    When you turn off airport, then turn it back on, do you see your router listed in the list of available networks? If so, when you click on it does it ask you for a password to log in? You aren't running a network without a password are you? Can you use wireless from another device such as a pc with wifi or an ipod touch?

    On the router from one of the wired machines, check the wireless settings. Does it have wireless even turned on? Does it have SSID broadcast turned on? Do you have it set to at least WEP and preferably WPA/PSK? Make sure you use a passphrase like "go2010SAINTS" that is hard to guess but easy to remember. The router will generate 26 digits of hex gobbledegook but you should be able to simply type the "go2010SAINTS" passphrase into any machine trying to use the wifi. Case is important. Usually when wifi connection fails, it is a password issue. Don't go around blowing away plists with dynamite. I'm sure this can be worked out with going in the terminal or blowing away configuration files. If that kind of nonsense was needed for Macs to use wifi, Apple wouldn't be in business.
     

Share This Page