Upgraded to Yosemite- can no longer access SharePoint sites

Discussion in 'OS X Yosemite (10.10)' started by shelhed217, Dec 31, 2014.

  1. shelhed217 macrumors member

    Joined:
    Mar 4, 2010
    Location:
    VA
    #1
    As background my MBPr is still on mavericks and the sharepoint websites all still work fine, Safari 7. I have tested on my husbands PC and in IE and firefox all of the websites still work.

    Upgraded my IMac to yosemite 10.10.1 and Safari 8.0.2, now 2 different sharepoint sites time out with a server not responding error about 90% of the time. I never get to the point where I can enter my credentials. I am still able to access the sharepoint sites in Chrome, however in Chrome I can't check out and edit documents so I can't just switch. In Firefox I get the same time out.

    Randomly and not often it works. As an example i logged in this morning and it was fine (did not work last night, i did nothing but put mac to sleep), however our internet went out briefly and since then it won't work.

    When i log in under my guest account on the iMac it works (have tried maybe 5 times today after reboots).

    I have tried to no avail:
    - checking and updating Java
    - wiped all remembered passwords for these sites in Keychain and Safari
    Safari- cleared history and web data
    - cleared cache from library folder
    - uninstalled all extensions
    - Changed DNS server to google (8.8.8.8 and 8.8.4.4) and turned on auto proxy discovery (tested on guest account after this change and still worked there)
    - Under privacy removed all website data (cookies)

    I don't know what else to do. thought I would check here before I try a clean install of Yosemite (I just did the app store upgrade of mavericks before).

    I would like to upgrade my MBPr next year but if I can't get my work stuff to work reliably in yosemite I will have to look at a PC laptop :( :( :(
    thanks
     
  2. Nermal, Dec 31, 2014
    Last edited: Jan 1, 2015

    Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #3
    If you don't have access to the compat.browser file then you can probably work around the issue by choosing Develop > User Agent > Safari 7.1.2. If you don't have the Develop menu then you can enable it in Safari's preferences, under Advanced.

    Edit: That was specifically in regard to McGiord's post, which probably won't help with timeouts. I'd only just woken up when I first saw this thread :)
     
  3. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #4
    OS X Yosemite connections to SharePoint sometimes time out

    For rapid reduction of the problem, go for Recovery OS Safari. Is the ~ninety percent failure rate reproducible in that relatively clean environment?

    Back to Safari in OS X and the ~ten percent of apparently good connections with those two SharePoint servers. After you authenticate, then is everything normal for each session?

    With Disk Utility, verify all HFS Plus file systems (don't rush to repair). Do they appear to be OK?

    Is Silverlight installed? Yosemite aside, that's a Microsoft product that troubles my use of Safari.

    Is the SharePoint browser plug-in installed?
     
  4. shelhed217 thread starter macrumors member

    Joined:
    Mar 4, 2010
    Location:
    VA
    #5
    Develop menu did not work, thank you though.

    I do not have access to the servers, this is a large healthcare organization that does not officially support Macs, i've just been using them for work for several years (until yosemite that is).

    Grahamperrin- As I said logged in as a guest user in yosemite it does work. I am not sure what you are referring to by "recovery OS safari"

    After I do authenticate everything is good and works as expected.

    The sharepoint browser plug in is installed. The silverlight browser plug in is also installed 5.1.30514.0 . When i go to Library/Internet Plug-ins I don't see silverlight there, i am not sure how else to uninstall it?

    I ran apple hardware test, all is good. I ran disk utility, all is good.

    I found another sharepoint server where it works 100% of the time.

    Help :(
     
  5. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #6
    Next …

    Sorry! I missed that part of the opening post.

    Start Recovery System then launch Safari.

    (I suggested that only because I hadn't paid attention to the opening post.)

    Removing Silverlight - MAC | Microsoft Silverlight

    I prefer to use Diablotin, I don't know whether Yosemite is compatible.

    Side note: http://www.microsoft.com/getsilverlight/Get-Started/Install/Default.aspx does not currently work with Safari in my Mavericks environment (it doesn't bother me).

    If you'd like to send me just one private message with the URLs of the SharePoint service(s) that are troublesome to you, I can tell (without attempting to log on) whether the same URLs are troublesome in another environment.
     

Share This Page