Upgraded Unactivated Jailbroken IPSW but on TMobile. Plz Help!

Discussion in 'Jailbreaks and iOS Hacks' started by SaintJohn, Oct 18, 2009.

  1. SaintJohn macrumors newbie

    Joined:
    Oct 18, 2009
    #1
    I'm a windows user so I had to rely on a pre-made custom IPSW. Turns out I got ahold of an unactivated version of the file instead of an activated one. I guess I should have done more research before I attempting.

    So I'm stuck with my iPhone in emergecy mode. I'm not sure how to fix this problem...

    I tried downgrading to my old custom 3.0 IPSW using DFU mode and iTunes, but iTunes fails telling me it can't verify the IPSW.

    Possible Options:

    - Somehow downgrade back to 3.0. I'm pretty sure my modem firmware wasn't upgraded, so I think it's possible, but I don't know how.

    - Borrow a friends ATT SIM, then install ultrasn0w, then hopefully my TMo sim will work?

    - Find an activated version of a custom IPSW and try DFU mode installing it. But I don't know if you can do that (3.1.2 -> 3.1.2)

    At this point, I'd be happy just go back to where I was at 3.0. Anything really to get my phone working again.

    Does anyone have any suggestions? I really appreciate the help!
     
  2. Nine9si macrumors member

    Joined:
    Apr 18, 2009
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0_1 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A400 Safari/528.16)

    Yes you can use an AT&T sim to activate.

    If your using a 3g you should be able to restore to 3.0.
     
  3. SaintJohn thread starter macrumors newbie

    Joined:
    Oct 18, 2009
    #3
    I have a 16GB 3GS, which was running 3.0 jailbroken/unlocked. Now it's got 3.1.2 jailbroken/locked/unactivated.

    I found a more reliable IPSW by reading this forum (too bad I didn't find this forum before I tried to jb/unlock).

    I'm going to try loading the activated IPSW over top of my current un-activated one. From reading the DevTeams blog it looks like I should be able to do this just fine.

    My only concern is I have to use DFU in order to shift-restore (otherwise iTunes just tells me it's an invalid SIM). I'm pretty sure this is ok, but I'm a little worried iTunes is going to tell me it's an invalid file during the verification process.

    I'll post on whether or not it works.

    (I'd rather not bother my friend today if I don't have to. Lives across town...)
     
  4. savior1974 macrumors regular

    Joined:
    Feb 17, 2009
    #4
    Go here.

    http://forums.macrumors.com/showthread.php?t=803052

    Download the Activated version.

    Shift restore it too your phone

    Your good to go :)
     
  5. SaintJohn thread starter macrumors newbie

    Joined:
    Oct 18, 2009
    #5
    I got the ipsw from the link you provided (found it earlier in the thread you linked to). Thanks savior!

    The problem is, I can't shift-restore because my current OS isn't activated. I just get "The SIM card inserted in this iPhone does not appear to be supported...." on the screen that normally has the Restore button.

    When I try restoring using DFU mode, I get a 1600 error and it won't install.

    Is there a way to force a normal restore? Or is there a way around the 1600 error (most posts I read said just do a normal restore)?

    Thanks!
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    Put your friends sim in the phone, let it activate, take it out and use the correct IPSW.
     
  7. savior1974 macrumors regular

    Joined:
    Feb 17, 2009
    #7


    What phone do you have?
     
  8. SaintJohn thread starter macrumors newbie

    Joined:
    Oct 18, 2009
    #8
    I got it working now. I just had to put it in recovery mode (not DFU) then it let me use the ipsw I downloaded from the link savior provided.

    So, for those who are getting 1600 or 1604 errors trying to shift-restore a custom ipsw from an already jailbroken iphone (mine is a 3gs). Don't use DFU mode to restore! Use recovery mode by doing the following:

    1. Disconnect iPhone from computer. I don't think I had itunes running, but I'm not sure that it matters.
    2. Turn off iPhone.
    3. Hold down home button and connect to usb cable.
    4. Keep holding down home button until itunes gives message that your iPhone is connected in recovery mode and must be restored.

    Once I did this, it allowed me to perform a shift-restore even though I had an unauthorized SIM card installed.

    The IPSW installed smoothly. I then restored the backup I took before I started this whole mess.

    After that, I just ran Cydia (let it update) and then installed ultrasn0w. Reboot and Viola!

    Jailbroken and unlocked and running 3.1.2. Not sure if it was worth the stress considering there's nothing remarkable about the update, but it's done.

    Thank you very much savior, your posts in other threads helped a ton.
     
  9. 1dumbiphoneuser macrumors newbie

    Joined:
    Oct 22, 2009
    #9
    help...

    My issues are exactly the same as yours, got a new "unactivated" iphone and I need to activate and unlock/jailbreak so I can use it on Tmobile's network.

    I've been reading this thread over and over again but still can't figure out what to do...(hence my screen name...) which file(s) do I need to download and what are the steps to unolock/jailbreak the 3GS??? are the steps below to put the iphone in "restore mode"
    thanks in advance!



     
  10. SaintJohn thread starter macrumors newbie

    Joined:
    Oct 18, 2009
    #10
    I'm not sure that your situation is exactly the same as mine. I had a previously jailbroken iPhone 3GS running 3.0.

    The main thing for you to check is your modem baseband firmware version (not sure if I said that exactly right). If you are running 05.11.07 then the phone cannot be unlocked yet.

    If you want to know what worked for me (lets assume you have an unlockable version of the modem firmware):

    Follow the link that savior1974 posted. There should be a link in that thread to an external site that has links to some IPSWs. Download the 2 files you need (they are RARs). I got the ACTIVATED 500 meg system partition for 3GS version (part1 and part2).

    You'll need a utility like WinRAR or 7zip (I prefer 7zip) to unrar the files into a single .IPSW file.

    Run iTunes in recovery mode to bypass the whole problem with connecting an unactivate iPhone problem.

    Hold down Shift and click restore. Select the IPSW you extracted earlier and let it restore.

    If you get a 16xx error during the restore process it might be because you don't have an already jailbroken phone. I never really saw a definitive answer on this. People have suggested various ways to get around it including:

    - Restore in Recovery mode (worked for me)
    - Restore normally (worked for me with the UNACTIVATED IPSW, but then couldn't get to the restore button when I tried to use the ACTIVATED version because my phone wasn't activated).
    - Restore in DFU mode (didn't work for me, got 1604 error)
    - Run a utility called IH8SN0W (don't know what this does, didn't need to use it)

    Good luck!
     

Share This Page