upgrading firmware

Discussion in 'Jailbreaks and iOS Hacks' started by forshtay, Nov 27, 2011.

  1. forshtay macrumors newbie

    Joined:
    Nov 27, 2011
    #1
    I have a jailbroken iphone 3gs with firmware 3.1.3. What is the best way to upgrade to firmware to 4.x.x? I want to upgrade because most apps I try to download say I need to be on at least 4.0.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    You would need the shsh saved. Open Cydia and see which ones are saved (on top of screen in green letters). Then either use PwnageTool or Snowbreeze.
     
  3. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #3
    you can upgrade to 4.1 without blob save. However, you have a 05.12 which is very valuable, so make sure to customs cook a 4.1 fw to preserve this baseband. Don't ever upgrade to apple official 4.1 fw, because if you do, your iPhone base band will also upgrade to 05.14.

    The reason you can upgrade to 4.1 is that somehow this fw still being signed by Apple. It is weird and I do not have explanation for it.
     
  4. forshtay thread starter macrumors newbie

    Joined:
    Nov 27, 2011
    #4
    When I open Cydia, it says SHSH: iOS 4.1. But my phone and itunes say I have 3.1.3. Which do I really have?
     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    Your phone has firmware of 3.1.3 on it which Itunes confirmed that as well. However, you have SHSH save for 4.1 which you can upgrade to that firmware without any problem.

    Download Tiny umbrella, run it and see what additional SHSH blobs save you have.
     
  6. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #6
    Download tiny umbrella to determine what SHSH you have. Plug your phone in and run the program and it will tell you which blobs you have. Then, upgrade to that firmware using your saved blobs for that version of 4.x.x you have blobs for.

    Please google instructions; upgrading/downgrading using blobs is asked on a daily basis and there are hundreds of guides. For starters, download the software .ipsw for your device and the most recent version of tiny umbrella.
     

Share This Page