upgrading hard drive question

Discussion in 'MacBook' started by BabaG, Oct 8, 2013.

  1. BabaG macrumors member

    Joined:
    Jan 5, 2007
    #1
    i was going to upgrade the hard drive in a friend's older macbook 4,1. the drive it came with is this:

    fujitsu mhy2250bh
    http://reviews.cnet.com/internal-hard-drives/fujitsu-mobile-mhy2250bh-hard/4505- 9998_7-32595467.html


    i was looking to upgrade it to this:

    Samsung’s Spinpoint M8
    http://www.newegg.com/Product/Product.aspx?Item=N82E16822152291

    i've done plenty of drive upgrades on my mac pro but never on a macbook. is there anything i need to be aware of, like, it needs special apple firmware or it won't work, things like that. or can i use off-the-shelf drives like i can in the mac pro?

    and, second, the macbook (4,1) is running 10.5. what's the max memory it can use? thought i'd look at upping that while i was at it. it currently has 4gb.

    thanks very much,
    BabaG
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Just like the Pro, any drive the correct physical size will work. There is nothing special needed as far as firmware.

    http://www.everymac.com

    Look up your machine on this site and it will show max memory and the specs.
     
  3. BabaG thread starter macrumors member

    Joined:
    Jan 5, 2007
  4. HIMAN1998 macrumors 6502

    HIMAN1998

    Joined:
    Jan 24, 2013
    Location:
    Richmond, VA
    #4
    The drive will need to be formatted as Mac OS X Extended (journaled) and have the GUID Partition Table partition scheme.
     
  5. jathca, Nov 9, 2013
    Last edited: Nov 9, 2013

    jathca macrumors newbie

    Joined:
    Nov 9, 2013
    #5
    Issues with changing to the Samsung Spinpoint M8

    I recently purchased this drive wanting to upgrade a friend's black Macbook from 250Gb to 500Gb. I've tried using disk utility to restore the existing hard drive onto this as an external then swapping it out and booting from it and I've tried Carbon Copy and created a bootable disk. The latter doesn't actually boot though. I swap out the drive and find that the Macbook claims that it can't find an operating system. I've even tired swapping it out on my own and the machine still says it can't find an operating system (flashing folder with a question mark). The funny thing is is that I can plug it in via USB on either machine and boot from it just fine but once I put it into either machine it doesn't work anymore.

    Help?

    Oh, and this is my friend's specs:

    http://www.everymac.com/systems/app...duo-2.4-black-13-early-2008-penryn-specs.html

    (though upgraded to 4G RAM)

    and my specs:

    http://www.everymac.com/systems/app...-2.4-aluminum-13-late-2008-unibody-specs.html

    (with 4G RAM)
     

Share This Page