Upgrading to Mavericks "Unknown Error (4)"

Discussion in 'OS X Mavericks (10.9)' started by jahall05, Oct 22, 2013.

  1. jahall05 macrumors regular

    Joined:
    Jul 30, 2013
    #1
    Hey guys,

    I have a mid-2012 cMBP 13. I go to the app store to upgrade to Mavericks and it says there is "Unknown Error" and then "The App Store could not process your request. (4)"

    Is this just the servers being bogged down by everyone wanting to update or is there something I am doing wrong?

    Thanks!
     
  2. MacGurl111 macrumors 65816

    MacGurl111

    Joined:
    Feb 4, 2010
    Location:
    Seattle
    #2
    Sounds like the server might be.. Keep trying.
     
  3. jahall05 thread starter macrumors regular

    Joined:
    Jul 30, 2013
    #3
    Resolved (Fix Possibly)

    Try this…go to Purchases (top bar on app store application), and it will probably prompt you to sign in. Sign in, and then go back to update and try it again. This solved the issues for me!
     
  4. Tremaet macrumors newbie

    Joined:
    Oct 22, 2013
    #4
    jahall05, thanks so much for the tip. That did the trick for me (going from Snow Leopard to Mavericks).
     
  5. RedEclipze macrumors newbie

    RedEclipze

    Joined:
    Aug 3, 2016
    Location:
    United States
  6. joviaust macrumors newbie

    Joined:
    Apr 1, 2017
    #6
    --- Post Merged, Apr 1, 2017 ---
    I just had the same error message while upgrading fromYosemite to Sierra and went to purchases first, Signed in and then everything was there for me to upgrade my system.
     

Share This Page