upload speed absurdly slow, whats happening? airport problem?

Discussion in 'MacBook Pro' started by Wanderer509, Nov 15, 2007.

  1. Wanderer509 macrumors member

    Joined:
    Oct 28, 2007
    #1
    hi, i am using a macbook C2D 2.16ghz with macosx 10.4.11. i have ran some speedtest on my macbook n have noticed a absurdly slow upload speed (DL:2600kb/s, UP:30kb/s). i was just wondering waht is wrong with this speed? does it have anything to do with my airport as i have heard before airport soemtimes have problems... n if so are there updates for it? i ran software update but nothing came up, so just searching around n trying to see if anyone knows =) thanks in advance

    in addition: my firefox always dont respond, keeps telling me its waiting for response, is this tied to the upload rate?
     
  2. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #2
    Try restarting your router.

    It also might a problem on your ISP's end.
     
  3. Wanderer509 thread starter macrumors member

    Joined:
    Oct 28, 2007
    #3
    i dont beleive its my router's problem, since i can get 500kb/s upload rates on my other computers. are there any airport updates that have to be applied manually taht software updater wont tell u about?

    EDIT: for some reason my upload speed is bak up, the only major thing i did was change my channel to 5 instead of 6. thanks anyways =D lets hope it doenst die again
     
  4. bhanu2217 macrumors newbie

    Joined:
    Jun 29, 2009
    #4


    I am facing the same issue. I have windows 7 also installed on my Mac.
    Internet works fine on Windows but on Mac i get very slow upload speed or u can call it no upload at all, its so slow that i cant even send e-mail but browsing/downloading works fine.

    I changed Wireless router channel from 6 to 5 but that didn't help either.
    I also tried adding DNS addresses but that didn't help either.
    Even the wired connection from router gives me same issue on MAC.
    if i connect the modem directly to the computer it works fine.

    I use a D-link wireless router model DI-524 and beetel adsl modem. Modem is connected to the router.

    Windows 7 on MAC doesn't give me any problem with the wireless or wired internet.

    I also updated the Firmware of the router that didn't help either.

    Firmware update link and instruction for ppl who are using the same router.
    http://www.dlink.com.au/tech/default.asp?model=DI-524&TemplateId=21654
    http://www.dlink.com.au/tech/Download/download.aspx?product=DI-524&revision=REV_B&filetype=Firmware

    The conclusion is my router doesn't seem to be working well with MAC but works fine with windows,anyone has solutions for this?

    I have finally found the solution:
    Here is it:


    Change the MTU from 1500 to 1200
    http://www.dlink.com.au/tech/default.asp?model=DI-524&TemplateId=21654
     
  5. JohnAtl1 macrumors newbie

    Joined:
    Dec 21, 2010
    #5
    Thanks!

    I changed the MTU setting on my MacBook Pro to 1200 and that fixed the slow upload/uplink speed. Thanks!
    I am house sitting, and thought I was going to be without (well, 0.01MB uplink) internet for 10 days :)

    John
     

Share This Page