iPhone URGENT: Cannot update to 6.1.2 - Stuck in DFU mode

Discussion in 'Jailbreaks and iOS Hacks' started by h4mza, Mar 30, 2013.

  1. h4mza macrumors 6502

    Joined:
    Jul 30, 2010
    #1
    I was on 5.1.1 and used tinyumbrella to retrieve my blobs. It saved 5.0.1, 5.1, 6.0.1, 6.1 and 6.1.2 blobs. So I downloaded 6.1.2 firmware and used snowbreeze to create a custom IPSW and used iTunes to restore it but it gave me an error that it couldn't be restored, so I was left stuck on DFU mode. :( My iPhone wouldn't even turn on at all, redsnow shows Soft DFU mode. I don't what it means :(

    So then I used iFaith to build a custom IPSW but it said my blobs apt ticket is not valid :(

    Now my iPhone is dead and I don't know what to do. I do not want 6.1.3 :mad: Any help will be appreciated :eek:
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    If you have an iPhone 4s or 5 you're stuck and having the blobs won't help you.
     
  3. h4mza thread starter macrumors 6502

    Joined:
    Jul 30, 2010
  4. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #4
    Your 6.1.2 shsh blobs are invalid. Download iFaith v1.5.6 or above. Click show caches from cydia's server. After it finds them, save them. If it says invalid, restoring to a specific firmware will put your device into a soft DFU mode.

    If say iFaith says iOS 6.1 shsh tickets are valid, restore using those 6.1 stitched shsh blobs

    If you have no valid iOS 6 shsh blobs, you are stuck on 6.1.3 and get a tethered jailbreak or downgrade to 5.0.1 to get an untethered jailbreak since it doesn't look like you have 5.1.1 shsh blobs (I'm not sure if you can downgrade from iOS 6 to iOS 5; I think you can though)
     
  5. Sile macrumors newbie

    Joined:
    Mar 31, 2013
    #5
    No shsh blobs...

    Hallo - I'm new here, but need help too.
    My son updated his 3GS iphone to 6.1.3, but the update failed, and the phone is now stuck in DFU mode. We tried to jailbreak it with RedSn0w, and this was partially successful, but now it's stuck in DFU mode. I tried
    RedSn0w again, and got the error message - Missing keys Plist data for this build. Doing a bit more investigating, I found that no shsh blobs were found, and the AP ticket was invalid. I've tried Tinyumbrella without success.
    Could you tell me where we go from here? How can we get the blods? I'm new to all this...
    Many thanks,
    Sile
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    If you have invalid shsh blobs, there is no way to fix it by getting new ones as apple is no longer signing iOS 6.1.2. If you really want your jailbreak, hope you have iOS 5.1.1 blobs so you can downgrade and jailbreak. If you don't and still want a jailbreak, the closest you can get is a tethered jailbreak on 6.1.3
     
  7. BiigBiscuit macrumors member

    Joined:
    Aug 23, 2011
    #7
    Not 100% sure, but I think you can jailbreak 6.1.3 on an iPhone 4 with Redsn0w.
     
  8. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #8
    It will be a tethered jailbreak. He/she would need a computer to boot up every time he restarts the puone
     
  9. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #9
    Better than nothing and with the 'new' Cydia hardly ever is a reboot required, mostly a respring is enough
     
  10. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #10
    I did mention in my post that it'll be a tethered jailbreak. I was just telling the person I quoted it was a tethered jailbreak and not an untethered one.

    For a tethered jailbreak, resprings don't require the computer? (I've never been on a tethered jailbreak so I wouldn't know)
     
  11. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #11
    Nope, just for a reboot, better to have untethered, but tethered is very usable.
     
  12. h4mza thread starter macrumors 6502

    Joined:
    Jul 30, 2010
    #12
    How would I go from tethered to untethered jailbreak? Lets say I am on tethered jailbreak and I have lots cracked apps and cydia tweaks. Once untethered jailbreak is released, do i just run the untethered jailbreak from either cydia or computer? Will my cracked apps and cydia tweaks remain there or be removed?
     
  13. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #13
    IF an untether becomes available usually you can install it in Cydia, for evasi0n it's called evasi0n 6.0-6.1.2 untether, for absinthe it was Rocky Racoon 5.1.1 untether.
     
  14. Sile macrumors newbie

    Joined:
    Mar 31, 2013
    #14
    Good evening...
    I've watched a lot of videos, and read a lot of forums, and I'm gradually getting a bit wiser - but can anyone tell me how I can find out which version iOS the 3GS which I'm trying to fix might have had? Any time I try to use RedSn0w it doesn't recognise the IPSW.
    iFaith fetched 6.1.6 (10B329) and 4.1 (8B117). They were submitted to Cydia, but I was "unable to continue with activation" All this and more...
    Any good ideas?
    Thanks,
    Sile
     
  15. Sile macrumors newbie

    Joined:
    Mar 31, 2013
  16. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #16
    What version are you trying to restore to?
     
  17. bushido Suspended

    bushido

    Joined:
    Mar 26, 2008
    Location:
    Germany
    #17
    i dont even know why i bother with saving blobs anymore tbh or why they tell everyone its so important... i dont even remember the last time i could actually use them to restore to anything thats not the latest OS :mad:
     
  18. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #18
    It's in case when an exploit has been found to downgrade for A5+ devices. Honestly, it's not that hard to save an shsh blob. If they did find an exploit for A5+ devices and you didn't save your shsh blob, you would probably regret it
     
  19. Sile macrumors newbie

    Joined:
    Mar 31, 2013
    #19
    Hi Darricksailo,
    I'm not sure. My son was on holiday when he received the update notice on his 3GS from Apple, but when he updated something went wrong. I think the update must have been 6.1.3, because that was released on 19th March (I think) which would have been around the right time, but I don't know what version was on it before.
    I "made" a stitched IPSW with iFaith yesterday, 000001FFD606AD76_iFaith_iPhone_3GS-6.1.3_(10B329)_signed.ipsw - do you think it's any good, and how should i use it?
    Any help would be appreciated,
    Sile
     
  20. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #20
    If you are trying to restore to 6.1.3, you don't need to make any stitched firmware

    Are you trying to restore to a firmware you can jailbreak?
     
  21. Sile macrumors newbie

    Joined:
    Mar 31, 2013
    #21
    Darricksailo, I would be happy to restore to 6.1.3 if it would make the phone work, and I could think about jailbreaking afterwards. At the moment, I think you would say that it's "bricked"! It will go into recovery mode, but that's all. I'm totally new to all this... but am learning!
     
  22. pnyc macrumors 6502

    Joined:
    May 12, 2007
    Location:
    Brooklyn, NY
    #22
    Did you try restoring from iTunes? The "regular" Apple restore? That should work and it should put you on the 6.1.3
     
  23. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #23
    i just checked for you and fortunately, you have iOS 5.1.1 shsh blobs!

    download the 5.1.1 ipsw: http://appldnld.apple.com/iOS5.1.1/041-4347.20120427.o2yov/iPhone2,1_5.1.1_9B206_Restore.ipsw

    download your iOS 5.1.1 shsh blob via iFaith

    use iFaith to stitch the shsh blob to the 5.1.1 ipsw package. afterwards, put your 3GS into pwned dfu mode (iFaith helps you after you finish making the custom package

    once your device is in pwned dfu mode, just shift + click restore and select that custom firmware package made.

    it will proceed to restore your iphone 3GS to iOS 5.1.1. next download absinthe: https://sites.google.com/site/greenpois0nabsinthe/absinthe-win-2.0.4.zip?attredirects=0&d=1

    and you now have a jailbroken iphone 3gs on iOS 5.1.1. I would recommend download "Software Update Killer" and "ResetAllKiller" from cydia immediately after jailbreaking the device
     
  24. Sile macrumors newbie

    Joined:
    Mar 31, 2013
    #24
    Darricksailo, thank you for all your efforts, I've spent the evening doing it. Everything went beautifully, until going into itunes to restore. I really thought it was going to work, it restored, and verified, but when it came to activate, after I'd entered our own details, it sent the message "Your phone could not be actified because the activation server is temporarily unavailabe etc. etc". Still, I got further this time than any time before...
    Any suggestions?
    Thanks again,
    Sile
     
  25. darricksailo, Apr 10, 2013
    Last edited: Apr 10, 2013

    darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #25
    Do you happen to know if the phone relied on a software unlock (ultrasn0w)? And which carrier it is tied to? If its AT&T, you can buy an IMEI unlock for around $5. I hear people mention about swiftunlocks so you can look into that. You could also go through the hassle of talking to an AT&T rep and asking them to unlock the device

    Once it's unlocked, just redo the restoring process with that custom firmware you made

    Edit: I'm not available to check right now to tell you the exact steps but I think the reason why you're stuck at the activation page is because you are on the iPad baseband. Google and check what your baseband/modem version is. Is it 6.15.00? If it is, downgrade it, I think redsn0w has this feature to downgrade it
     

Share This Page