URGENT!!! DVD Studio Pro 4 problems with assets

Discussion in 'Digital Video' started by The Valeyard, Oct 13, 2011.

  1. The Valeyard macrumors member

    Joined:
    Apr 26, 2009
    #1
    I have this project to complete by Monday and it's not working at the final stage.

    I have done all my menus and audio and assets but when I went to build/format to do a test run it always stopped on the one asset during the muxing stage. I read that I should try deleting the PAR files and restarting the program which I did but now the program won't open. It quits unexectedly whenever it tries to parse the assets.

    How do I fix this?! I cannot redo it all from scratch, there is no time. Please, somebody help!
     
  2. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #2
    I managed to get past it by making it delink the file then relinking it but I'm still having trouble with it not reading the video file.

    I edited this in Final Cut Pro, then on to Compressor then into DVD Studio Pro whereby I added 29 chapter markers.

    Here is the readout from the log:

    Starting DVD Build CLUEDO...
    Compiler Initializing...
    Precompiling Project CLUEDO
    Compiling VMG Information...
    Created 12 PGCs in VTSM1
    Created 5 PGCs in VTSM2
    Created 8 PGCs in VMG.
    6 Menu(s) will be created...
    Compiling Menu PGCs...
    Compiling Menu#1 (Menu 1)...
    Rendering Menu:Menu 1,Language:1...
    Compiling Menu#2 (Menu 3)...
    Rendering Menu:Menu 3,Language:1...
    Compiling Menu#3 (Menu 4)...
    Rendering Menu:Menu 4,Language:1...
    Compiling Menu#4 (Menu 5)...
    Rendering Menu:Menu 5,Language:1...
    Compiling Menu#5 (Menu 6)...
    Rendering Menu:Menu 6,Language:1...
    Compiling Menu#6 (Menu 7)...
    Rendering Menu:Menu 7,Language:1...
    Writing VIDEO_TS.VOB
    Compiling Menu PGCs...
    Writing VTS_02_0.VOB
    2 VTSs and 2 Titles will be created...
    Compiling VTS#1 (CluedoFvDL)...
    Muxing VTS_01_1.VOB
    Video File Read Error

    Build cancelled
    Building was not successful. See log.
     
  3. MovieCutter macrumors 68040

    MovieCutter

    Joined:
    May 3, 2005
    Location:
    Washington, DC
    #3
    Try skipping Compressor and exporting a file natively from FCP and let DVDSP do the encoding. Either Compressor screwed something up or something else. But from the log your video file isn't playing nice with DVDSP
     
  4. VideoCave macrumors member

    Joined:
    Mar 16, 2011
    Location:
    OC
    #4
    re dvdsp

    Dont use DSP to do the encoding of the videos. Use compresser to pre-encode your video then drop in to DSP. That way there is less of a chance of something going wrong on the build part. Images are fine because they are small in file size.

    Also here's a couple things of what might be causing you problems.

    1. The video you are putting into DSP. Is it a compressed codec or uncompressed? If its compressed it might not like it. Thats another reason why its better to use Compresser to encode your video because it doesn't care. Unless its a format it doesn't except.

    2. If you have any images make sure they are in RGB not CMYK and were built to match the menu size of your project. And just to be safe I would save as a jpeg unless you need the transparency of tiff for some reason.

    3. The RAM you have installed in your computer is Apple Certified or cheap 3rd party from the store? Video is very intensive for the computer and if the memory is bad you will have problems.

    These are all issues I have had figure out thats why I recommend them to you.
     
  5. LethalWolfe macrumors G3

    LethalWolfe

    Joined:
    Jan 11, 2002
    Location:
    Los Angeles
    #5
    What settings did you use in Compressor?


    Lethal
     
  6. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #6
    I have been using compressor to encode all my assets.

    These are the settings I have been using to compress the video:

    Name: De-interlace 16:9
    Description: No description
    File Extension: m2v
    Estimated size: 2.2 GB/hour of source
    Type: MPEG-2 video elementary stream
    Usage:SD DVD
    Video Encoder
    Format: M2V
    Width: 720
    Height: 576
    Pixel aspect ratio: PAL CCIR 601 (16:9)
    Crop: None
    Padding: None
    Frame rate: 25
    Frame Controls On:
    Retiming: (Fast) Nearest Frame
    Resize Filter: Statistical Prediction
    Deinterlace Filter: Best (Motion Compensated)
    Adaptive Details: On
    Antialias: 0
    Detail Level: 0
    Field Output: Progressive
    Start timecode from source
    Aspect ratio: 16:9
    Field dominance: Automatic
    Average bit rate: 5 (Mbps)
    1 Pass VBR enabled
    Maximum bit rate: 7.5 (Mbps)
    High quality
    Best motion estimation
    Closed GOP Size: 12, Structure: IBBP
    DVD Studio Pro meta-data enabled

    And I have been using "Dolby Digital Professional 2.0 copy" for the audio
     
  7. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #7
    I did a simple test with a rebuild and the second title, using the exact same settings, builds perfectly but the other file still fails.

    It has nothing to do with chapter markers but I just cant work out what's wrong with it and I probably don't have to time to compress it again since it took 2 days the last time.
     
  8. KeithPratt macrumors 6502a

    Joined:
    Mar 6, 2007
    #8
    If you change the deinterlace setting to 'better' it'll be so so so much quicker.
     
  9. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #9
    Will that make the video look noticably worse?
     
  10. Richardthe4th macrumors regular

    Joined:
    Jan 4, 2008
    Location:
    Below Sealevel
    #10
    Good call. Made me look further. Field output is set to progressive.

    But if you make a dvd (=tv), that is interlaced. There is no use in de-interlacing. Is your original source interlaced (I guess so)? Then export that, run it through compressor with the options on the original interlaced.
     
  11. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #11
    Here's the strange thing, actually. I did that originally and it looked horrible, basically. The motion was far too smooth and looked very strange. I then did a test run with a de-interlaced version (using MPEG Streamclip rather than compressor) and it looked far better.

    Interestingly enough, though, when I have done other projects using iMovie with iDVD I have not had the overly smooth motion problem and looks much better on the TV.

    Also, it's noticable as I have done some freezes on video during acton where a lot of jittering occurs on the TV screen which adds to the horrible effect more than the strangely smooth motion.

    I don't exactly know how to describe it but it looks like the clips have been sped up from what I've been editing with, yet strangely they're keeping the same time.
     
  12. Richardthe4th macrumors regular

    Joined:
    Jan 4, 2008
    Location:
    Below Sealevel
    #12
    I assume you are using fcp, right?

    You have to use a deinterlace filter in the editor (fcp) for this, before you export. Just on the freeze-frame parts and/or stills.

    On tv or a computer monitor? Will give very different results.

    What are the settings of your source material? iPhone (30 fps)? I'm getting the feeling there is something strange from the beginning.

    Can you describe what the settings are from your source material? Sequence-settings?

    And since you're on a deadline, while you are investigating, just let DVDSP crunch it. It won't deinterlace, perhaps you're lucky with good results.
     
  13. The Valeyard thread starter macrumors member

    Joined:
    Apr 26, 2009
    #13
    The TV. I did an interlaced version and noticed the problem immediately, then did a de-interlaced version and it looked far better.


    And my source is a PAL MiniDV tape camcorder. It appears to use anamorphic widescreen (720x576, then something done to it to make it proper).

    I am considering getting a new camera as tapes are obsolete (but being an unemployed student puts a dampener on that idea) that has 1080p HD.
     

Share This Page