URGENT HELP- ATI 5870 crashes ...:(

Discussion in 'Mac Pro' started by arunpg123, Oct 29, 2012.

  1. arunpg123 macrumors newbie

    Joined:
    Sep 22, 2008
    #1
    Hi all @ macrumors,

    I am in need of an urgent help.

    I just got my ATI Radeon HD 5870 graphics card for my mac pro.
    I cant load anything . I tried previewing a quicktime movie file, it crashes.
    Same with safari. cant even load it.

    even in firefox, it shows flash player error.
    tried updating flash player, but in vain .

    This is my config

    Model Name: Mac Pro
    Model Identifier: MacPro4,1
    Processor Name: Quad-Core Intel Xeon
    Processor Speed: 2.26 GHz
    Number of Processors: 2
    Total Number of Cores: 8
    L2 Cache (per Core): 256 KB
    L3 Cache (per Processor): 8 MB
    Memory: 24 GB

    I have LED cinema display 24 inch. (‪24-inch, Late 2008‬ (1920 x 1200)

    HDD :

    512 GB SSD
    2 TB SATA Disk
    6 TB Lacie (as a RAID Drive)



    Can someone guide me pls.....
    thanks

    Aroonz
     
  2. DanielCoffey macrumors 65816

    DanielCoffey

    Joined:
    Nov 15, 2010
    Location:
    Edinburgh, UK
    #2
    We need more specific information if we are to help.

    "Just got..." implies you just bought it so use your warranty.

    "it crashes" is too vague to help diagnose the issue.
     
  3. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #3
    Couple of things to check.

    Are you running 10.6.4 or higher?

    Is this an Apple 5870, or a stock PC one?

    Have you installed it into the correct slot (PCI slots 3 or 4, which run at 16x)
     
  4. cutterman macrumors regular

    Joined:
    Apr 27, 2010
  5. arunpg123 thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #5
    i did connect 2 power leads

    ----------

    yea. its in the last slot - no 4 i guess.. the one away from the drive bays.


    Yea. i have warranty. I thought i would check with you guys before i go for it :D



    THANKSSSSSS for all your replies. Looking forward to a solution.

    thank you guys..
     
  6. Asgorath macrumors 65816

    Joined:
    Mar 30, 2012
    #6
    No, if it's under warranty, you should contact the official support. That's what it's for.
     
  7. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #7
    This.
     
  8. arunpg123 thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #8
    Thanks mate for the advise. I was looking for someone with a solution !!!

    Anyways, i have contacted the service center ..
     
  9. arunpg123 thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #9
    again :(

    i got the replacement from apple.

    installed the new card.. got it working.. but same probs with flash player and quicktime.

    what can be done ? any idea guys ?
     
  10. All Taken macrumors 6502a

    Joined:
    Dec 28, 2009
    Location:
    UK
    #10
    Try a fresh install of OS X, try the card under Windows.
     
  11. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #11
    Post a Crash Log and what is your OS?

    There is another user here with similar problems, lots of them with safari, reinstalled but does not make a difference, so crash log and OS version.
     
  12. MacVidCards Suspended

    Joined:
    Nov 17, 2008
    Location:
    Hollywood, CA
    #12
    Which OS?

    Requires 10.6.5 or later to work right
     
  13. arunpg123 thread starter macrumors newbie

    Joined:
    Sep 22, 2008
    #13
    I have osx 10.8.2.
    Did the other guy had his problems sorted out.. does he also run 10.8 >??

    here is the crash log from quicktime. i swapped the graphics card and i havent saved the log.
    Let me know if this image helps. else i will put the gfx card again and get u the log in text format :

    http://www.freeimagehosting.net/y7knj



    i have higher version

    ----------


    Its high time i try that :)

    ----------

    UPDATE

    I tried swapping 5870 with 5770 (my friend had one)
    5870 worked fine on his mac. It implies that the new gfx card is error free.

    That made me try 5770 on mine. It gave me the same crashes.
    only difference between the mac's is the OSX. I run 10.8.2 and he has 10.6

    So it must be a prob with osx. I guess i should try a fresh install....
    Right... ?





     
  14. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #14
    After reading all the Posts again I think your best bet is to try a clean install, but instead of reinstalling on the main disk you could try to install a fresh copy on a USB stick, minimum 8GB or so, select as little as possibel, so no print drivers or languages.
    If the problems persist try an earlier OS version, 10.6.8 would be a good choice, if it persists on ML there could be a bug, if it's gone in Lion or SL you know crappy ML is the cause and you are not the only one with problems with Lion or Mountain Lion.
     

Share This Page