Urgent help needed! Recovering an encrypted RAID Drive...

Discussion in 'Mac Basics and Help' started by crampon23, Aug 25, 2013.

  1. crampon23 macrumors newbie

    Joined:
    Aug 25, 2013
    #1
    First, I appreciate any help that can be offered here. I have many irreplaceable files that my job depends on and need this solved ASAP. I am really freaking out here and to make matters worse, I am traveling in Thailand.

    I have an external Western Digital 2TB drive configured in RAID1 (2 * 2TB drives inside of it).

    All was working normally when all of a sudden today I plugged the drive in and instead of asking me for the device encryption password (I'm using filevault on this disk) like it normally does, it asked me for the password and another pop-up asked if I would like to use this drive as a timemachine backup drive.

    The drive now appears as the default "MyBook" and is completely empty. Where did my files go and how do I get them back??

    The disk is also no longer asking me for the FileVault password..

    • Running OSX 10.8
    • HFS+ File System on the external drive
    • Tried to run disk utility to no avail. It says the drive is fine.
    • WD Drive Manager also says everything is fine.

    I'm guessing something is wrong with partition tables but no idea how to fix this.

    tia...
     
  2. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #2
    "I'm guessing something is wrong with partition tables but no idea how to fix this."

    Well, that's what happens when you use RAID for storage without a backup -- and try to _encrypt_ the whole thing as well.

    RAID can be a very fragile technology if you rely on it without a backup. I would never depend on it -- particularly in a situation where I was traveling and didn't have easy access to my backups.

    And the encryption only makes it worse...
     
  3. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
  4. crampon23 thread starter macrumors newbie

    Joined:
    Aug 25, 2013
    #4
    Ugh, dude you are completely right. I was in the middle of backing up to CrashPlan but it was copying my system's internal computer first.

    Still, I had it set this way for a while so I realize I did this to myself. Just unlucky this happened as I was actually keeping a proper backup...

    Is there any way I can rebuild the partition table? As far as I know the data is still there and if the partition table is rebuilt it should be visible to my mac, and thus I can decrypt as normal.
     
  5. MacForScience macrumors 6502

    MacForScience

    Joined:
    Sep 7, 2010
    Location:
    USA
    #5
    Does the RAID give you any status lights? The Western Digital RAIDs will I believe give a yellow status light if the RAID degrades. That would be the first thing to check.

    The point about backing up is a good one, but to be fair RAID 1 is safer than other options (RAID 0), as it does provide redundancy.

    Cheers
     

Share This Page