Urgent help needed [superduper doesnt allow me to restore compressed user folder]

Discussion in 'Mac Apps and Mac App Store' started by anmolgoel, May 16, 2013.

  1. anmolgoel, May 16, 2013
    Last edited: May 16, 2013

    anmolgoel macrumors newbie

    May 16, 2013

    I'm in deep trouble right now and need some serious help.

    I'm using macbook pro with Mountain lion (upgraded first from snow leopard to lion and then ML). My notebook was getting heated up and getting slower so I decided to do a clean re-install.

    For data backup, I wanted to use super duper. I didnt want to make a clone of my HD because if i restored the disk clone then all the problems would come back.
    So I chose option backup- user files (which backs up only the users folder).

    Then I realized my backup HDD was acting funny and so couldnt be trusted. I had no other spare disks to format so I backed it into a disk image thinking I will mount and restore it later from the resulting dmg, but I unknowingly checked compression as low instead of none. [See attached image to see what the options looked like]. The trouble started here!

    Now when I did a clean reinstall, superduper doesnt allow me to restore user folder as it is in use.
    I tried mounting the image and manually copying my data, but no file is working since I compressed it.
    Now I'm stuck in a soup where I can see all my files but I cannot access them. When I try to open the dmg files inside that backup, it says invalid dmg file. Even the text files are all opening as blanks.
    Can anyone help me! I will be soo grateful!

    Thanks in advance.

    Attached Files:

  2. jdblas69 macrumors regular

    Aug 15, 2012
    Have you tried to verify the .dmg image you created in disk utility? Maybe the file is corrupt??
  3. anmolgoel, May 16, 2013
    Last edited: May 17, 2013

    anmolgoel thread starter macrumors newbie

    May 16, 2013
    Yes I have done that.. It says "The volume Macintosh HD appears to be OK."

    Also i restored it into a blank hard drive, like the usual process and all the files are unusable there as well.. i cannot understand.

    EDIT: Some files are usable (around 10%). I cannot establish a clear link as to why they are working and others aren't
  4. Fishrrman macrumors G5


    Feb 20, 2009
    I know this comes too late to help now, but…

    … if you had just used SuperDuper (or CarbonCopyCloner) to create a "full", UNcompressed "clone" of your internal hard drive, you wouldn't be having these problems today.

    The entire purpose of a "cloned, bootable backup" is to make recovery EASY, insofar as getting at your files is concerned. You WANT files in easy-to-reach, uncompressed "Finder format". If the files are of a sensitive nature, lock them up, but otherwise keep them easy to "get at" in an emergency.

    "Compression" is poison for backing up. If you can't decompress, you've got problems.

    NEXT TIME, don't bother with that "disk image" notion or use compression. Just do a basic clone. Keep things simple.
  5. anmolgoel, May 19, 2013
    Last edited: May 19, 2013

    anmolgoel thread starter macrumors newbie

    May 16, 2013

    Learnt my lesson for the future mate.. i need a solution to recover my work now..!

Share This Page