*URGENT* iPhone 3GS 4.2.1 Stuck in Recovery Loop, Help Needed ASAP

Discussion in 'Jailbreaks and iOS Hacks' started by Agent 21, Mar 1, 2011.

  1. Agent 21 macrumors regular

    Joined:
    Jun 27, 2009
    #1
    I searched the forums for "iphone stuck in recovery mode" and didn't get any relevant results for my particular problem:

    OK, so I am away on vacation and I was talking on the phone and all of the sudden it died. I had like 30-40% battery left last time I checked (right before answering the call) and was talking for like 5 minutes tops when it just shut off. OK I thought, thats weird but whatever, just put it on charger. So I do and as soon as it turns on it kicks over to the recovery screen (the USB + iTunes logo screen), and has been there ever since (about 4hrs now). I have NO CLUE why it would do this. I am Jailbroken ands its a launch day 3GS and it was always untethered (4.2.1 FW and used RedSn0w) for the past month and I restarted or had the battery die plenty of times since jailbreaking and it's always booted up fine, never tethered.

    NOTHING I do gets me out of that screen either. I have searched SO many YouTube tutorials and none work. I've tried the iRecovery and iReb things, nothing. And they all want you to use that LibUSB (is that the name? something along those lines) thing but when I install it on Windows 7 (running it in XP compatibility mode like the tutorials say) it doesn't work. They all say a BUNCH of text should come up once you run it after the install, but nothing comes up on mine. One tutorial even said if you don't get the wall of text then something went wrong (but no mention on what or how to fix it).

    My problem is, I am on vacation and so I don't have the computer with all the backups on it, and I wont be home for 3 weeks. I don't want to completely restore and lose all the stuff, I NEED access to things on the phone on this trip, its kinda critical actually. Is there ANY way to kick it out of this mode? I don't even know why it entered it, its so random!

    This is VERY very important and words can't express how appreciative I will be if anyone helps me solve this.

    Its a launch-day 3GS, 4.2.1, RedSn0w JB (was always untethered and never once had an issue rebooting it), and the PC is Windows 7 64-bit. I DO have the RedSn0w and custom FW files on this computer, as this is the one I jailbroke on, if that helps at all. Maybe treating it like a tethered JB and starting up that way would work? If anyone thinks that could work, how would I go about doing that (booting up as a "tethered" JB)? I need to regain access to my phone within the next few hrs if at all possible.
     
  2. labman, Mar 1, 2011
    Last edited: Mar 1, 2011
  3. Agent 21 thread starter macrumors regular

    Joined:
    Jun 27, 2009
    #3
    OK so I decided to try the tethered boot but the new problem is the PHONE WONT TURN OFF!!!!!!

    In order to do it (in RedSn0w anyway), it specifically states to turn the phone off and NOT to press next until it is..........but it wont stay off. I can't just hold the lock button until the red power bar comes up to slide it off, because it is just stuck on the iTunes/USB screen, and no matter what I try in terms or just holding lock button until it turns off or any combo of the lock/home keys, no matter what it just turns itself right back on, the apple logo then the recovery screen.

    It stays off when NOT plugged in to the computer, but as long as that USB is connected to the phone and the computer, it just turns right back on automatically. I'm getting SO pissed right now...........
     
  4. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #4
    Download tinyumbrella, open it, click your phone, then click "Exit Recovery"

    http://thefirmwareumbrella.blogspot.com/
     
  5. Agent 21 thread starter macrumors regular

    Joined:
    Jun 27, 2009
    #5
    I'm a Windows user and it says that its just for Mac and he's "working on" the windows one :(

    I just "bit the bullet" and restored (its doing so as we speak), I had no other choice, I NEEDED the phone by a certain time. Sucks that I lost recent files, but it's better than nothing at all for 3 weeks. Though I'll admit, when I saw that post about TinyUmbrella my heart sank for a minute, as I had JUST clicked "restore" literally SECONDS before coming back and reading that suggestion.

    This sucks so much. I have such a love/hate relationship with the iPhone lol. I mostly love it, but stuff like this makes me want to throw it against a wall. This isn't the first time this happened. Well, its the first time THIS actual issue happened, but back in about mid-January the phone also turned itself off when I had 70% battery AND it was on the charger while I was using it. That time it just stayed on the battery charging screen with the little red sliver............for 2 days. I chalked it up to still running 3.0 jailbroken, thought maybe the problems were from such an old FW, but now a "similar" issue happened I'm thinking it's gotta be a hardware issue.

    I ALMOST bought a 4 when that last issue happened, because I have the upgrade, but then I figured, why waste it now when in a few months the 5 will be out (going simply by an educated guess as a new iPhone seems to come out every summer for the last 3 years). Maybe the 5 won't be any better (I'm dreading the day they make an iphone with a physical keyboard like some mock-ups have shown, KILLING the "sleekness" of it), but then I can get a 4 even cheaper lol.

    Thanks for the suggestions though everyone :)
     
  6. navigates macrumors 6502a

    Joined:
    Jul 13, 2008
    #6
    Did you replace the battery. Ios4 looks for the correct battery part number. If the part number does not match the original one, then it throws the Error 29 and stuck on recovery. Check your original battery part number.
     
  7. kre62 macrumors 68000

    Joined:
    Jul 12, 2010
    #7
    Right hand side, download link for windows bro. Hes talking about the newest beta. But the current version works just fine. Im a windows user as well. You jumped the gun on that one. Oh well, sorry you ended up restoring.
     
  8. Agent 21 thread starter macrumors regular

    Joined:
    Jun 27, 2009
    #8
    No, everything is still exactly how it was on launch day, but thanks for asking that bewcause I was actually browsing eBay looking for a replacement battery thinking maybe that could be an issue. It DOES randomly turn off a lot when it still says I have 30% battery, so I was thinking maybe the battery was going. If there is an issue though then I'm not gonna replace it, I'll just try to stick out out until summer and a new iPhone comes out (or I just get the 4). But yeah now that I think of it it seems to always turn off on me at 30%, so like my phone really only has 70% battery. Curiously enough it NEVER happens on a Wi-Fi network, just 3G............hmmmm. Maybe this restore fixed that issue.

    I did see that, which confused me as it said it was just for Mac currently. I was thinking maybe that one was the regular TinyUmbrella but the new one was the one that fixed the 4.2.1 Recovery Loop issue, and that the fix was only available for Macs right now. Oh well, moot point since I had already started the process before I saw your reply anyway.

    But again, thanks for all the info everyone.
     
  9. Darwing macrumors 6502

    Joined:
    Nov 5, 2009
    #9
    OMG I got the same issue, only today I tried to restore my phone to 4.2.1, and it came up with a error 1013, so I searched up the error and tried deleting the gs.apple.xxx from the host file, (which I read to do to fix the error) and it still got that error upon restore (phone just stays in recovery).

    Was on the phone with Apple for like 3hrs, troubleshooting and working on different things to get it out of the recovery... Nothing, They even took control of my computer and watched as I did all the testing and restore etc. Nothing.

    Before all that I tried tinyumbrella and easyirecouvery to knock it out of the loop. Nothing.

    So they are sending me a new phone tomorrow (I have the protection plan). Its a pain in the ass but apple has such amazing costumer service, its amazing you can get a new phone shipped to you the very next day.

    However, is this a common problem after you jailbreak with greenpoison and then try to restore?
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Please don't try jailbreaking again. The 1013 error is normal when iTunes can't complete the baseband upgrade. Greenpois0n, TinyUmbrella or RecBoot will indeed kick it out of the loop.

    With you getting free phones from Apple, they are gonna have to raise the price for the rest of us.
     
  11. Darwing macrumors 6502

    Joined:
    Nov 5, 2009
    #11
    thanks for the outrageous comment and smart ass connotation to the reply.

    If your going to quote someone next time actually read the post where it said

    and stop being a smartass.
     

Share This Page