URGENT: Keyboard Backlight 15" MBP late08

Discussion in 'MacBook Pro' started by KptIglo, Jan 23, 2011.

  1. KptIglo macrumors member

    Joined:
    Jan 14, 2004
    #1
    hi

    does anybody know, if the kb bl ribon cable
    (STEP 21:
    http://www.ifixit.com/Guide/Repair/...ody-Late-2008-and-Early-2009-Upper-Case/838/7 )

    is only for the power supply and for the kb itself is another cable?

    i need to know, cause the mbp got a motherboard swap (cause of the flickering screen problem) and know i wanna sell it, but today i've detected that the bl isn't working :-(
    the sensors are working and the F5&F6 keys also. i've tried reseting smc, pram, hardware test, labtick and systemstart from dvd without luck
    so it only can be (hopefully) that the power supply cable of the bl must be disconnected (if the power and kb data cable are different ones, otherwise the kb must be without function) or, the bl is defect.

    plzzzzzzz help, cause the book is already sold and before i try to fix the cable disconnect and it's only cable for both (bl & kb data), there's the only way to contact apple care tomorrow and hope that the seller will be patient....

    thx alot and kind regards

    p.s. sorry 4 my english ;-)
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    If you have the intention of selling it or if it's already sold, I wouldn't try to mess around with it hoping it's one component if it's something else. You would risk more trying to fix it yourself than to lose a customer by taking it back to the Apple Store.
     
  3. KptIglo thread starter macrumors member

    Joined:
    Jan 14, 2004
    #3
    it's no problem for me
    i've already taken apart and assembled most of all mac models and iphones too...
    but i'm asking before wasting time
     
  4. KptIglo thread starter macrumors member

    Joined:
    Jan 14, 2004
    #4
    Solved

    ok, got it

    it's a separate cable ;-)

    and the superior apple service provider idiots forgotten the power cable under the fan :mad:
     

Share This Page