iPad US App Store on Jailbroken iPad 2 Instead of UK

Discussion in 'Jailbreaks and iOS Hacks' started by dannyo92, Jun 6, 2012.

  1. dannyo92 macrumors newbie

    Joined:
    Jun 6, 2012
    #1
    I used Absinthe 2.0 to jailbreak my iPad 2 running iOS 5.1.1. It has worked, but I have noticed that the App Store is now the US version rather than the UK version, i.e. apps show up in $ rather than £ and there are some apps that show up that aren't available in the UK.

    Is there anything I can do to get back the UK app store? I am still logged into my UK iTunes account as I was before.

    Thanks :)
     
  2. Dav1, Jun 6, 2012
    Last edited: Jun 6, 2012

    Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #2
    When you first go through and set up your iPad there is an option to select the country, could you have accepted the default setting?

    Have you tried going into settings and resetting your region?

    Just editing and rebooting doesn't seem to change my app store to the UK, :( so that's unlikely to be the answer. Sorry...
     
  3. ipsychedelic macrumors 6502a

    ipsychedelic

    Joined:
    Mar 8, 2012
    #3
    Just a stupid thought, but what if you try to download a US-only app (e.g Lose It! or Amazon or USPS or UPS, only sure about the first one 100%), it should ask you to switch stores since you have an UK account.
    At least, that's what the theory says.
     
  4. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
  5. dannyo92 thread starter macrumors newbie

    Joined:
    Jun 6, 2012
    #5
    I've just had another look at it seems that it's only apps under the top charts tab that shows up in dollars with US-only apps. If I try to open one then it just says your request cannot be completed.

    If I search for apps or go to ones under featured then they are all in pounds rather than dollars and no US-only apps show up.

    So it looks like I've answered my own question. I might try restoring my iPad a re-jailbreaking it to see if that helps, because I do like looking through the charts and seeing what is free for a limited time or whatever.

    Thanks for your help.
     
  6. Dav1 macrumors 6502

    Joined:
    Mar 14, 2011
    #6
    If you restore it, I'd suggest that as soon as you get the iTunes message your device is rebooting, please leave it connected. That you switch to the iPad and set it up as new, and verify that the app store is working correctly. (if you unplug it when you get that message ~ you can set it up as new on the iPad, verify it is working correctly, and then dock it to iTunes and complete the restore) if you then get the same condition you'll know it is an issue with your backup...
     
  7. dannyo92 thread starter macrumors newbie

    Joined:
    Jun 6, 2012
    #7
    Well, everything seems to be working now all of a sudden. I updated some apps and once I returned to the app store it was the UK one again. Not quite sure why it's fixed but I'm happy it's all sorted. Thanks again for your help.
     

Share This Page