US-International Keyboard with Dead keys possible?

Discussion in 'Mac Basics and Help' started by Heleen, Nov 20, 2008.

  1. Heleen macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #1
    Hello,

    2 Weeks ago I bought my first Mac: the new MacBook (5.1). As a previous Windows and Linux user I absolutely love my Mac, it suits my needs as a designer and programmer perfectly.
    However there's one thing that really bothers me: I can't find a way to turn my keyboard mappings into US - International WITH dead keys.
    I am Dutch and we use a lot of accents on our letters (though not as much as the French and Germans). I find the way that Apple has implemented these on a US-International keyboard (which is the keyboard all Dutch people use) really inefficient and I prefer the Windows or Linux way of dealing with it: you type the ' and then the e and you get é, or " and e is ë (hehe, I had to search to get this one: u for umlaut).
    You might say that I'll just have to get used to it, but I believe it really slows me down in typing. I love my Mac and this is pretty much the only thing that really annoys me.

    Anyway, is there anyone (maybe some other Dutch person) who's found a solution for this? I would be very grateful :).

    Heleen
     
  2. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #2
    Heleen - have you tried Character Palette (CP) from your country flag in the top menu bar? Or go System Preferences > International > Input Menu. In CP, you can choose European Scripts > Latin, where you'll find numerous special letters that may well suit your purposes.
     
  3. Heleen thread starter macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #3
    Thanks. I hadn't tried that yet. But it seems that I can't change the short key (or how I would type a character) for any character in Character Panel. I can only view characters and add them to my favorite characters (I can't immediately see the use of that, they don't appear in the keyboard shortcuts menu).
    My problem is not that I don't know how to find the special characters but that I find the way you type those special characters (e.g. using alt+e and then another e for é) is uncomfortable for me and I would like to change that to either the way Windows does it or the way Linux (Ubuntu) does it (you just type ' and e for é).
    Thanks for your reply though :).
     
  4. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #4
    Yes, I understand that you want key strokes for the letters, and that CP involves a lot off toggling, mouse clicks etc, but what about clicking the Dutch option in International > Input Menu? Does that not provide the special characters from the keyboard for you?
     
  5. Heleen thread starter macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #5
    No, unfortunately not. The key strokes using the Dutch 'keyboard' are the same as when I set it to USA Extended. Setting the language or region to Dutch instead of English doesn't work either. I tried setting it to Belgian as well, but apparently they have quite a different keyboard, so that doen't work either.
    Thanks for the help so far!
     
  6. tingiminn macrumors newbie

    Joined:
    Nov 21, 2008
    Location:
    At some geospatial coördinates
    #6
  7. Heleen thread starter macrumors newbie

    Heleen

    Joined:
    Oct 25, 2008
    Location:
    York, UK
    #7
    Thank you very much! That's exactly what I was looking for. I even thought of writing something like that myself if nothing was available, but this is excellent, it saves me a lot of time :D.
    Thanks again!
     
  8. tingiminn macrumors newbie

    Joined:
    Nov 21, 2008
    Location:
    At some geospatial coördinates

Share This Page