Usage same as Standby bug - can't fix

Discussion in 'iOS 7' started by Ashin, Sep 16, 2013.

  1. Ashin macrumors 6502a

    Ashin

    Joined:
    Jun 19, 2010
    #1
    For me iOS7 was going great, until now.

    My battery life is awful today, I checked the usage and usage and standby are identical... the last unique thing I did was set a reminder, but after deleting it the usage is still going up in standby.

    I tried toggling Reminders in all my accounts, then disabling... didn't work, now I just deleted every account and iCloud, and rebooted my phone... still doing it.

    This is a few day old DFU restore, restored via iCloud, then reset all settings, and it has gone to hell this easily?

    I just don't know what to say or do... sure the typical Macrumors fix will be "restore it", but why should I have to when it's still pretty much clean restored.

    iOS6 is looking tempting again...

    By the way, judging from my debugging it seems to have something to do with calaccessd - always restarting... can't stop it.
     
  2. treichert macrumors 6502

    Joined:
    Nov 7, 2007
    Location:
    Aachen, Germany
    #2
    Reboot it.

    I run into this occasional since iOS 6 and a reboot has always fixed it.
     
  3. KeanosMagicHat macrumors 65816

    Joined:
    May 18, 2012
    #3
    This doesn't look like a bug, in that it's working for me on a 4S with iOS 7 GM. Perhaps it's an incompatibility with one of your apps getting stuck in an always running state?

    What I've never liked about iOS is that even when this is working, however, usage is reported as a component of standby.

    e.g. if standby is 10 hours and usage is 2, it means true standby is actually 8 hours.

    They probably do this so that some people add the figures together and so think that their battery life is better than it actually is.

    I'd rather see the true times reported for both.
     
  4. Ashin thread starter macrumors 6502a

    Ashin

    Joined:
    Jun 19, 2010
    #4
    I know how the usage stats are shown.

    If it says 2 hours 5 minutes usage and 2 hours 5 minutes standby there is a problem, especially when you've not even used it more than 5 minutes.

    Anyway, I fixed it now anyway.

    Removing iCloud, and all my email accounts, rebooting, then adding them all again did it.

    I suspect the process of restoring accounts to a new iOS version can cause glitches in the settings, or simply does not get set up properly since you are bypassing the mechanics to set up push and what not... my educated guess would say iOS goes into a loop because it wants it all set up properly, but the settings have been put in place by the restore.

    What makes me even more suspicious of this being the problem is that after deleting all my accounts the springboard crashed - gives me the impression something was corrupt during the restoring of the accounts... oh well, crisis averted

    tl;dr - iOS7 battery drain could be fixed by removing any restored iCloud or email accounts and setting them up again as new
     
  5. KeanosMagicHat macrumors 65816

    Joined:
    May 18, 2012
    #5
    Wasn't meaning to come off antagonistic, glad you've sorted your problem and was merely making a related point for the benefit of other forum members, who may be unaware.
     

Share This Page