USB 3.0 interference

Discussion in 'MacBook Pro' started by satinsilverem2, Feb 14, 2015.

  1. satinsilverem2 macrumors 6502

    satinsilverem2

    Joined:
    Nov 12, 2013
    Location:
    Richmond, VA
    #1
    I use my 2011 MacBook Pro in a dock and use the Apple wireless keyboard and magic trackpad. Ever since I upgraded to a thunderbolt dock and usb 3.0 drives, when ever I'm transferring a lot of data on the drives or doing a Time Machine backup my mouse and keyboard are just about unusable. They either become jerky and lag or just connect then disconnect over and over again. Ive been dealing with this for a couple of months now. Ive been so fed up with it that I've gone back to the wired keyboard and a crappy windows mouse to bypass the issue. I really miss the trackpad and keyboard for the gestures and the clean wireless look. Ive tried just about everything to combat the issue such as locating the mac closer to the devices and moving the hard drives further away. Ive even swapped the usb cables out for better shielded ones with no success. Is there anything else that I could do to improve the bluetooth reliability?
     
  2. BeatCrazy macrumors 6502a

    Joined:
    Jul 20, 2011
    #2
    Did you ever get a resolution to this?
     
  3. satinsilverem2 thread starter macrumors 6502

    satinsilverem2

    Joined:
    Nov 12, 2013
    Location:
    Richmond, VA
    #3
    I ended up getting a USB bluetooth 4.0 receiver to use with the new Magic Trackpad and Magic Keyboard. I haven't had an issue since then even while transferring large amounts of data. Also the upgrade to 4.0 enabled me to take advantage of Yosemite's continuity features. I think the underlying issue is insufficient shielding in the internal bluetooth module.
     
  4. BeatCrazy macrumors 6502a

    Joined:
    Jul 20, 2011
    #4
    Cool. Yes, I'm using a BT 4.0 dongle as well, even though my Mac is a Late 2014 model. I get to use continuity as expected, but no Handoff functionality.

    I think it's more the shielding in the external USB 3.0 devices, rather than the internal BT module. I have a Thunderbolt dock. I tried connected my USB 3.0 HDDs to it, and using a standard 1m TB cable, but that didn't help. Maybe I'll try a 2m cable and some better placement. I would like to get Handoff enabled, like I had with the built-in module.
     

Share This Page