USB 3 device working at 480Mbps

Discussion in 'MacBook Pro' started by figus, Jan 26, 2017.

  1. figus macrumors newbie

    Joined:
    Jan 26, 2017
    #1
    Hello everyone!

    I've been puzzled a little bit over this issue...

    The issue is with one USB memory, it is a Samsung USB 3.0 Flash Drive Fit 128GB.
    My computer is a MacBook Pro Early 2015.

    I connected it to the right port and the speed is displayed as "Up to 480 Mb/sec", So I thought something must be wrong... either with my port or my memory.
    So I connected the memory to the left port, now the speed is displayed as "Up to 5Gb/sec"
    It seems the memory is Ok, but maybe the right port is busted...

    To test, I took out 2 of my USB 3.0 HDD and connected them.
    Both are displayed as "Up to 5Gb/sec" on both ports, it seems both ports are Ok.

    The issue only comes with that memory on the right port...

    While I was scratching my head I saw an USB 3 extension cable, I hooked it up to the right port and the memory to the extension cable... to my surprise, now it is detected as "Up to 5Gb/sec" I was like "What?!"
    Why would it be detected correctly with the extension cable but not when it is connected directly to the computer?

    I did a Google search and some pages recommended to do a SMC and NVRAM reset, so I did, but nothing changed.

    Has someone faced this issue? do you have any recommendations?

    Thank you.

    Right port:
    usb der.png

    Left port:
    usb izq.png

    Right port using extension cable:
    ext der.png
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    The only difference is the available mA. For some reason the Mac isn't allowing it to draw as much power from the right port unless there's an extension cable plugged in, though it works natively on the left port. I'm not sure if the mA would affect the speeds, especially because it only needs to draw ~300mA, but going on your screenshots that's the only consistency between the speed drops.

    Do you possibly still have AppleCare on the machine? Also can you use any other USB drive for testing purposes and have a look at the available mA through the left/right port, with and without a cable?
     
  3. figus thread starter macrumors newbie

    Joined:
    Jan 26, 2017
    #3
    Hello!!

    Sadly, I don't have AppleCare

    I don't have any other USB Stick, but I have 2 USB 3.0 HDD, for which I attach the images

    HDD1 is the original 500GB PS4 drive in a Seagate Expansion Enclosure.

    HDD1.png

    HDD2 is a Toshiba Canvio 1TB that I bought around 2011, I guess I should get a newer one :
    HDD2.png

    PS. Thinking it was a Mac Os Issue (why not? haha, if the extension cable worked ) I booted into Windows 10, but same issue happened with the Samsung USB device.... (testing with CrystalMark because I don't know how to get the speed information)
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hello! Thank you so much for taking the time to go through all those troubleshooting steps.

    Hmm that's very odd. You can see in your screenshots that the Current Available is 900 in each instance, no matter what device you're using. It only seems to drop to 500 with that Samsung Flash Drive directly into your right-hand port.

    So that leaves us with:

    1) Software related: however as you've tested this in Windows (very helpful!) and it's doing the same thing, it's unlikely to be software.

    2) Hardware related: this is where it gets a bit tricky. The immediate thought would be that it can't be the USB stick, as it runs full speed on a different port, so possibly it's the right-hand port on your Mac that's faulty. However all other devices have the correct Current Available output of 900mA, so the problem just seems to be isolated to one peripheral, which would indicate the stick's somehow at fault.

    3) The Current Available at 900mA has no bearing whatsoever on the speeds and it's just a coincidence that the drop in current correlates to the drop in performance, meaning the problem is somewhere else. :confused:

    I'd suggest popping into a local Apple Store, if you have one near you. Try the sticks in their 2015 machines and see if it has the same decrease in performance, and/or the same decrease in maximum current. That would definitely help troubleshoot the problem! I'd probably recommend taking in your machine too, just so they don't get too suspicious about what you're doing. :)

    If not, did you buy your USB stick from Amazon? If you did, I'd recommend returning and get a new one, then test with that. This should help isolate if the problem is with the Mac or with the stick.

    Sorry I don't have any real answers, just more troubleshooting; but hopefully if you can do one of the above two steps, we'll get a little closer to cracking this mystery!

    All the best.
     
  5. figus thread starter macrumors newbie

    Joined:
    Jan 26, 2017
    #5
    Thank you for your time!!

    indeed I bought the drive in Amazon, but since I'm in Australia, I think the return would cost more than the drive itself.... hehe.

    I guess I'll drop by the Apple Store or ask one of my friends to test in their Mac.

    I'm actually a little suspicious....
    When I got it I left it plugged in, so it has been plugged in for about 1 week on the same port (right).

    I used to run a Win 7 VM every now and then (with USB 3 drivers) and mount it there to format it as NTFS for some tests I was doing... but today... I tried to do that same thing and windows told me that the device would perform better in a different port.... that's the only reason why I checked the speed information and came up with that surprise O_O

    That message didn't pop up before... win 7 vm used to load it normally....

    Is it a bad idea to plug it in and forget it there?? should I be disconnecting it??
    Right now I have it in the working port...will it happen there too?? O_O now I'm scared, haha

    Thank you!!
     
  6. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #6
    Aah right, I've heard AUS Amazon returns aren't quite as accomodating as they are elsewhere. :(

    Annoyingly that message in Windows about "this device can perform faster" can be caused by either a faulty USB device or a faulty USB port, so we're back to square one!

    I think it would just be best to take in your Mac to the Apple Store and have a poke around on some other machines of your model to see if the problem is the same. If it doesn't occur, it's worth a shot for them to check over your Mac at the Genius Bar.

    Although I don't think it would damage the other port (Macs will cut power to ports if they detect they're pulling too much juice or are shorting), it can't hurt to leave it unplugged for the time being, until you've been to the Apple Store.

    Please let us know how you get on, hopefully all will be okay. :)
     
  7. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #7
    Best workaround solution:
    Use the port "that works the best".

    Sometimes, that's all "that works"...
     

Share This Page