USB Audio Card no Surround Sound

Discussion in 'Mac Basics and Help' started by Wehrdo, Dec 26, 2010.

  1. Wehrdo macrumors newbie

    Wehrdo

    Joined:
    Dec 26, 2010
    Location:
    Midwest US
    #1
    I recently got this USB sound card, and in the Audio MIDI Setup Utility I can choose it as the default output, and under the Output Tab choose 6 channel.

    The problem is when I go to Configure Speakers. I can choose 5.1 setup, and click on each bubble and it will play out the respective speaker, but when I quit the application and re-open Audio MIDI Setup, 6 channel is still there, but under Configure Speakers, it reverts back to Stereo. Also, when I play a DVD in DVD Player or VLC, sound only player from two speakers and subwoofer.

    Thanks you so much for your help!!
     
  2. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #2
    I have a very similar card with the same C-MEDIA chipset, can't get it to work at all. I even managed to find a simple driver for it which ended up allowing my 5.1 speakers to produce a burst of sound, but honestly you probably won't get this card to work at all. You'll need to buy speakers that send their sound over an optical connection.
     
  3. Wehrdo, Dec 27, 2010
    Last edited: Dec 28, 2010

    Wehrdo thread starter macrumors newbie

    Wehrdo

    Joined:
    Dec 26, 2010
    Location:
    Midwest US
    #3
    EDIT: I have solved the issue. Apparently, you can only make changes to the multichannel setup under Configure Speakers when logged in as administrator, so if you log in as administrator and then set up your sound card settings, you can log in as your regular account and the settings have been changed.

    DVD Player won't play DVD's in surround sound, but if you use VLC, you can play video files and DVDs in surround sound, because it sends the audio to the right channels instead of mixing it down to stereo.

    _________________________________________________________________________________________________

    If I understood you right, your card doesn't work at all?

    Everything for my card works, just not the surround sound. I can play stereo out of it fine, record through the microphone jack, and in the Audio MIDI Setup, play out of each speaker, but no surround sound.

    Do you know of any special decoder for 5.1 sound? I think the DVD Player just sends the compressed Dolby Digital 5.1 from DVD's directly through the Toslink, so there is no decoding going on. Is a special decoder needed so it can be sent out the correct jacks in the USB card?
     

Share This Page