USB Audio Interfaces require new drivers?

Discussion in 'OS X Yosemite (10.10)' started by VirtualRain, Jul 27, 2014.

  1. VirtualRain macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #1
    Will USB audio interfaces require new drivers for Yosemite or will Mavericks drivers work?

    This is always the biggest PITA when a new OS X release comes out... My USB audio interface vendor is slow as molasses at updating drivers. :(
     
  2. robertosh macrumors 6502a

    robertosh

    Joined:
    Mar 2, 2011
    Location:
    Spain
    #2
    I have a Scarlett 6i6 usb audio interface in my iMac (with Mavericks), i will try to connect it to my macbook (with Yosemite) and try what happens with the current drivers.

    I'll tell you later
     
  3. blipmusic macrumors regular

    Joined:
    Feb 4, 2011
    #3
    Just tried my SPL Crimson with drivers installed in Reason and it seemed to work fine. Haven't done any recording or more extensive testing yet, though. The audio settings are a bit slow to react to changes, e.g. changing samplerate (Reason 7.1.1, quick enough on Mavericks), but that's all so far.

    Sometimes I get no system audio at all after sleep (2012 Macbook Pro Retina) on external.
     
  4. silvetti macrumors 6502a

    silvetti

    Joined:
    Nov 24, 2011
    Location:
    Poland
    #4
    My Apogee JAM works out of the box on Yosemite PB1.

    I have an Apogee ONE I can test later tonight.
     
  5. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #5
    Anyone have a UAD Apollo or any UAD device under Yos?
     
  6. VirtualRain thread starter macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #6
    Thanks... look forward to your findings.
     
  7. robertosh macrumors 6502a

    robertosh

    Joined:
    Mar 2, 2011
    Location:
    Spain
    #7
    I've tried iTunes and some day to day tasks with no problem with the sound card. I'm installing Logic and some plugins to test it in a better way. I'll post the results later today.
     
  8. jonbauer macrumors member

    Joined:
    Jan 28, 2011
    #8
    My Audioengine D1 seems to work ok as well...

    - Jon
     
  9. Jungo macrumors regular

    Joined:
    Aug 1, 2007
    #9
    My saffire Pro 24 is a NO GO... Focusrite is working on it.

    My Scarlett 2i4 running class compliant IS working.
     
  10. VirtualRain thread starter macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #10
    So it would seem to be device/driver specific and not a case of all 10.9 drivers being compatible with 10.10. Hmmm. I guess I'll have to see how my Lexicon IO22 does in 10.10 the hard way :(
     

Share This Page