Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPad USB-C Audio not working on iPadOS

AKKanMan

macrumors newbie
Original poster
Jun 28, 2019
7
0
Has anyone else had a problem using headphones connected using an USB-C to audio jack adapter? Audio just comes out the iPads speakers instead of the headphones. I never had a problem using the adapter before updating to iPadOS/iOS13.
 

DGGoingUphill

macrumors member
Jul 11, 2015
86
50
Has anyone else had a problem using headphones connected using an USB-C to audio jack adapter? Audio just comes out the iPads speakers instead of the headphones. I never had a problem using the adapter before updating to iPadOS/iOS13.

No problem for me using the Apple adapter with headphones. Also works as expected with a Line 6 Helix Stomp Via USB B to C adapter. Check your AirPlay settings, at it seems to have changed a little. The headphones now are listed as USB C to headphone jack, or something like that. Maybe you need to select them based on your previous setting?
 
Comment

AKKanMan

macrumors newbie
Original poster
Jun 28, 2019
7
0
No problem for me using the Apple adapter with headphones. Also works as expected with a Line 6 Helix Stomp Via USB B to C adapter. Check your AirPlay settings, at it seems to have changed a little. The headphones now are listed as USB C to headphone jack, or something like that. Maybe you need to select them based on your previous setting?

This may be a stupid question, but where would I check the AirPlay settings....I don’t seem to see it in the Settings App.
 
Comment

khhntz

macrumors member
Jun 21, 2010
43
0
California
Has anyone else had a problem using headphones connected using an USB-C to audio jack adapter? Audio just comes out the iPads speakers instead of the headphones. I never had a problem using the adapter before updating to iPadOS/iOS13.

Same situation here on my iPad Pro 2.

Prior to the beta the headphone works through a third-party (not Apple) USB-C to headphone adapter. However since iPadOS and now public beta 3 it has not worked.

I tried two different headphones and I even tried the adapter made by Apple and there is no sound through the headphones.

I also tried the same on my iPhone X (running the latest public beta iOS 13) and the sound works through the two headphones albeit via a different adapter.

I did also tried the AirPlay setting mentioned about but that didn’t work.

Lastly I tried connecting through a USB-C hub and nothing.

I hope Apple knows about this issue especially on an iPad. But I did also just submit the issue using the Feedback app that comes with the beta OS.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.